ReleaseNotes:New Features and Changes in 9.0 SR0

From OriginLab Wiki

Jump to: navigation, search


Contents

[edit] Key New Features and Changes in Origin 9.0 SR0



  1. 3D OpenGL Graphing
  2. 3D Parametric Function Plot
  3. Movie/Animation Creation
  4. Data Filter
  5. Graphing
  6. Floating Graph in Worksheet
  7. Global Vertical Cursor
  8. Implicit Function Fitting(Pro Only)
  9. IIR Filter Design(Pro Only)



[edit] Useful Links

[edit] 3D OpenGL Graphing

Faster plotting and visualization such as rotation. Improved performance for handling large data sets.

[edit] 3D Surface

JIRA Summary Details
ORG-936 Plot 3D surface directly from XYZ data. Including either categorical or text XY data.
ORG-3326 Include mesh lines (gridlines) on Surface Plots. Controlled by the Mesh tab located in the Plot Details dialog.
ORG-3219, ORG-1321, ORG-5201 New way to plot projection and stacked surfaces.
  • New menu and button to create Colormap Surface with Projection.
  • Shift surface in Z direction (0 to 100% of Z Scale).
  • Flatten surface.
ORG-4681 Allow Transparency on different components of Surface Plot. Including surface, mesh, and sidewalls.
ORG-5023 Color control in Surface.
  • Support colormap from other matrix.
  • New fill piece by piece mode to use Direct RGB, Index or Colormap from a matrix.
ORG-84 Intersection for surfaces with different XY data.
ORG-5000, ORG-6345 Contour lines on Surface Plot.
  • Enable/Disable contour lines on surface plots.
  • It's supported for XYZ surface plot as well.
  • Select contour line and customize it.
ORG-3219 Changes in the Plot Details dialog.
  • Enable checkbox on different tabs to easily turn on/off some components.
  • New Surface tab, Fill, Colormap/Contour, Mesh, Error Bar, and Side Walls tab added to the Plot Details dialog.

[edit] 3D Scatter and 3D Vector

JIRA Summary Details
ORG-3391 2D and 3D shapes for scatters.
  • For 3D shapes: cube, ball, star, and tetrahedron.
  • For 2D, only dots are supported.
ORG-1321 Shift scatter plot in Z direction.
ORG-4554 Plot 3D scatter from either categorical or text XY data.
ORG-5941 Special point support for 3D scatter graph made directly from XYZ data. Support customizing symbol, label, dropline, and error bars of special points.
ORG-6393 Put Labels at Arrow head or tail. For 3D Vector graph, provide options to put labels at the head or tail of arrows.
ORG-5797 Hide Open/Close radio buttons for 3D Vector. There is problem when using Open arrows. So we hide them. Only closed Arrows will be used.

[edit] 3D Bars

JIRA Summary Details
ORG-5339, ORG-1698 Plot 3D bar directly from XYZ data (new in 9) or Matrix data. Including 3D XYZ Bar with categorical or Text XY data.
ORG-1321 Shift bars in Z direction.
ORG-4451 Draw Bars from control. There is a dropdown list in Plot Details dialog to specify the start value of the bar. Two options now: Zero or Minimum.
ORG-5803, ORG-6217, ORG-4734 New Pattern tab in the Plot Details dialog.
  • Same GUI for 3D XYZ Bar, Matrix Bar, and XYY Bar plots.
  • New Excel style Gradient filling for 3D bars.
ORG-6221 New Spacing tab in the Plot Details dialog.
  • Same GUI for 3D XYZ Bar, Matrix Bar, and XYY Bar plots.
  • Support Keep square shape for XY face or adjust each separately.
ORG-5871 Special point support for 3D XYY bars.
  • Support customizing bar patterns of special bar.

[edit] Error Bar support in 3D Graphs

JIRA Summary Details
ORG-5732, ORG-5340, ORG-2546 Error bar support. Error bar support in 3D scatter, 3D Bar, XYY bar, and 3D Surface plots. Note: Surface plotted from XYZ data doesn't support error bars.
ORG-5380 New Error Bar tab in the Plot Details dialog. Supports 4 types of caps: None, X Line, Y Line, X Y Line.
ORG-5338 Error bars in X, Y, and Z directions. This is only supported in 3D Scatter plot from XYZ columns.
ORG-5662 Show error bar in projection.
ORG-5483 Select Error bars for easy access.
  • Select error bars in 3D graph to change color.
  • Double-click error bars to directly open the Error bar tab of the Plot Details dialog.
ORG-5756 Color controls for error bars.
  • <auto> to follow symbol or bar border color; single color, colormap, indexing, direct RGB as color, etc.
  • Transparency support for error bars.

[edit] Data Labeling Support in 3D Graphs

JIRA Summary Details
ORG-2281 Data Labeling in 3D scatter plot.
  • Label Form and Display control of labels.
  • Position and X, Y, and Z offset and orientation of labels.
  • Auto orientation of labels.
ORG-5941 Customizing label of special point in Plot from XYZ columns.
  • Ctrl+Select.
  • Ctrl+double-click a label to open Plot Details dialog.
ORG-5953 Drawing a lead line from data point to label.
  • set %c -ql nType; // set lead line type
  • set %c -qlc nColor; //set lead line color
  • set %c -qlw dWidth; //set lead line width
  • A threshold value @LLT to control the minimum distance that allows the leader line to show. Default is 100, which means the minimum distance between the data point and the label must be greater than 100% of the label font height.

[edit] Shading and Lighting in 3D Graphs

JIRA Summary Details
ORG-5734 Lighting button on Style toolbar. It will open Independent Lighting dialog for controlling lighting source directions and and properties.
ORG-912 Lighting tab in the Plot Details dialog. On Layer level of the Plot Details dialog.
ORG-2950 Dynamic lighting. On Lighting tab of the Plot Details dialog.
ORG-912 LT access of Lighting properties. Run "doc -uwfp;" after making changes to refresh the graph. This allows user to change several options for lighting and refresh at the end. If refreshing on each change, the operation may slow down and cause flashing.
  • layer.light.mode
  • layer.light.direction.h
  • layer.light.direction.v
  • layer.light.direction.dynamic
  • layer.light.ambient
  • layer.light.diffuse
  • layer.light.specular
  • layer.light.shininess
  • layer.light.ka
  • layer.light.kd
  • layer.light.ks

[edit] New 3D Axis Dialog

JIRA Summary Details
ORG-5528, ORG-5991 New Axis dialog with tree nodes for the X, Y, and Z axes.
  • Including reorganization of each node to make them more readable.
  • Show checkboxes on higher levels to control options in sub-nodes easily.
ORG-6463 Support a pair of Axis for each direction.
  • For X Axis, support Bottom and Top Axis.
  • For Y Axis, support Bottom and Top Axis.
  • For Z Axis, support Left and Right Axis.
  • Note: For XYY plot, for Y axis, support Left and Right axis; for Z axis, support Bottom and Top axis.
ORG-5991 Easy way to format X, Y, and Z axes together. Select Others button to select corresponding nodes in X, Y, and Z axes to edit them together.
ORG-6623 LabTalk access of X, Y and Z axes.

[edit] Layer and Planes in OpenGL

JIRA Summary Details
ORG-1411 Transparent support for Axis planes. Support setting axis planes to be transparent.
ORG-6284 Cube and Plane Border controls. On Planes tab, Cube group and Plane Border group is added.
  • Cube can be set to None, Front Corner or Whole Cube.
  • Plane Border control.
  • Color, Style, and Width control for cube and plane borders.
ORG-1072 X, Y, and Z clipping. On Miscellaneous tab of Layer level in the Plot Details dialog. We used to support X and Y clipping only.

[edit] Ease of Use controls

JIRA Summary Details
ORG-5513, ORG-5518 Plotting related menu/toolbar/dialog changes.
  • Reorganize menus and toolbar buttons for OpenGL graphing.
  • Add/Remove Plots from Layer Contents and Plot Setup dialogs.
  • Change Plot Types in Layer Contents, Plot Setup and Plot Details dialogs.
  • Updates in Template Library.
  • Improved the rule to open Plot Setup or Plot Virtual Matrix dialog based on data in worksheet.
ORG-4565 Better selection feedback for elements in OpenGL plotting.
  • For surface plot, even symbols show on selected surface.
  • For bars and 3D scatter, frames show around each bar and scatter points.
ORG-1420, ORG-6054, ORG-5824, ORG-3104 Rotate, resize, and move 3D Graphs.
  • Freehand rotation button and hotkey (R) for it.
  • OpenGL object transform icons.
  • Reset button.
  • LT command to rotate.
layer -3D R Z 1; // R <axis=X|Y|Z> <degrees=-N to +N>
layer -3D R Y 2;
layer -3D R X 4;

  • Select in blank area of 3D Frame to select the cube. If only surface shows in a 3D Graph, Alt+click on the 3D surface will select the cube. Then resize or move the cube.
ORG-3245, ORG-3149, ORG-5720 Move Axis planes and Axis.
  • Set axis plane locations by Auto/From Bottom/At Position on Plane tab of Plot Details dialog.
  • When plane position is not Auto, user can interactively move planes.
  • Move Axis, Axis Tick Labels, Axis Titles interactively or move in Axis dialog.
  • Moving Axis Planes and Axis together.
ORG-7038 Zoom and Panning Support Zoom in up to 1600%
ORG-2687 LT command to duplicate existing 3D layer into new OpenGL graph
  • "win -dg" duplicate the current graph window as a new graph and convert to OpenGL graph.
  • "layer -3d c" convert the current layer to OpenGL.
ORG-4691 Allow 2D text in 3D OpenGL graphs.
  • Right click or click T button on Tools toolbar to add 2D text.
  • Manipulate these 2D text objects in the same way as in 2D layers: Move, Resize, change properties using toolbars, edit in place, etc.

[edit] OpenGL Settings and Reminders

JIRA Summary Details
ORG-6501 Check and customize OpenGL settings. Tools: 3D OpenGL Settings... menu.
ORG-6636 Inform users about OpenGL failure like crashing next time Origin starts. If Origin crashes because of plotting/customizing 3D graphs, the next time Origin starts, a reminder message will popup, suggesting user to turn off transparency and anti-aliasing.
ORG-4459 Run @ogl=0 to plot Non-OpenGL Graphs. To plot non-OpenGL graphs all the time, user can go to Tools: System Variables dialog. Specify OGL to be 0 for all future sessions.

[edit] 3D Parametric Function Plot

Plot parametric functions in 3D such a Torus. Extension of 2D parametric plots already available in 8.6.

JIRA Summary Details
ORG-5657 File: New: Function Plot: 3D Parametric Function Plot menu.
  • Added user-defined Parametric Function Plot.
  • LT support in Function Plot.
  • Add parametric function to an existing 3D Graph.
  • Function tab added in Plot Details for function plot settings.
ORG-5015 Provide sample 3D Parametric function plots.
ORG-5923 New File extension (OFP) for function plot themes.
  • User can share it with others and for future usage.
  • Drag and drop ofp file into Origin to install the theme and use it.

[edit] Graphing

[edit] Plotting Improvements

JIRA Summary Details
ORG-8 Context menu to quickly change Data Plots in a layer. Right click a plot in a graph and choose Change X and Change Y context menus.
  • It only supports changing X and Y's to other columns in same worksheet.
  • User can only change X/Y for one plot at a time. Therefore for grouped plot, need to click twice to select a single plot and use Change X and Y context menus.
ORG-3399 Easy way to turn on/off data plots in a graph layer.
  • Add Hide Data Plot and Hide Others context menus when right click symbols in legend.
  • Shift+double-click a symbol in legend will hide the data in the plot.

[edit] Graphing Improvements

JIRA Summary Details
ORG-2924, ORG-2948, ORG-5986, ORG-60 Scientific Notation improvements.
  • Support show power of ten (10^3) Scientific Notation. It's supported in Tick Labels, Color Scale objects, and Contour Labels.
  • For 1E3 kind of Scientific notation, Leading zero after E can be hidden.
ORG-5956 Transparency Support for 2D graphic rectangle and circle shapes. There are two ways to set it.
  • Right click the graph object and choose Copy the format: All Style Formats context menu. Then right click on the object, press "Shift" key and select Paste Format context menu. In the dialog that opened, set Transparent.
  • There is a new property TRANSPARENCY of Graph object. E.g. After creating a rectangle object called rect. Run rect.transparency = 50 in Script window to set the transparency to 50.
ORG-735 Add a button named Reset to Native Aspect Ratio in Object Properties dialog would restore the Aspect ratio to the native For gr Objects that has a source, like an image, or a table object, click the button.
ORG-1996 Legend Custom Format support combining various LT substitution notation.
  • Allow combining various meta data elements with custom string seperator: E.g. @WS: @LL: @LD1
  • Added more substitution notations, e.g.
    • User parameter row header
    • Book and Sheet Comment
    • Allow access to individual row of comment
  • Fixed some substitution notations that are not working.
    • Range String failed for X
    • Failed to support sampling interval's longname
    • Dataset Name failed for X
ORG-4726 Option for error bars to have same color as data point
ORG-4218 Support Numeric, Time, Date, Tick-indexed string etc. tick label types for Radar Chart's dialog Also provide 5 types of diff Display (Decimal, Scientific, Engineering, etc.)
ORG-5423 Use %(x$), %(y$), %(z$) to show data label of categorical data. E.g. Suppose X is categorical data. After plotting, if user wants to show x info. as data label, go to Label tab of Plot Details dialog. Select Label Form: Custom and then use %(x$) as Format String.
ORG-6715 Gradient color control for 2D and 3D Bars. We also have system variable to control how Gradient is interpreted.
  • @OGLGD, default value is 1, which means the gradient direction will follow the direction of data

[edit] Dialogs related to Plotting/Graphing

JIRA Summary Details
ORG-5458 Redesign Insert Information Variable dialog. Only supported link variable with Column Index before 9.0. So if plot changes in a graph, the inserted variable could not update accordingly.
  • Support Link with plot Index.
  • Label tab is active by default.
  • Redesigned the preview window on the right panel to easily find Plots and corresponding X and Y columns.
ORG-2893 Book Name checkbox in context menu of left and right panels of Layer Contents dialog. It follows Project Explorer's Name column. If there is a long name, show long name of the book. If there is no long name, show short name of the book.
ORG-4280 Replace folder style GUI with list style in Graph Browser. Also additional columns are supported in the Graph browser, such as Path, Layers, and Plots to help user decide which graph to use.
ORG-5706 Added option to turn off consolidation when editing theme tree from the GUI. Better control of properties in the Graph Theme Editor by turning off consolidation of similar-items-properties so each item will be listed separately.
  • @TCT=0 will disable consolidation and globalization of theme nodes now.
  • Old user can use @TCT>100 (e.g. @TCT=101) to turn off consolidation.

[edit] Ternary Plot Improvements

JIRA Summary Details
ORG-1989 Support Clockwise rotation of axes in a Ternary plot. Added a tab in the Plot Details dialog to allow Clockwise and Counter clockwise rotation by selecting the appropriate radio button.
ORG-4814 Add a Label to the Ternary plot by drag and drop. If user has a label column after Z column to indicate data in a ternary graph. The user can highlight the label column, then move the mouse over the edge of the column till it changed into a graph icon, then drag and drop it into a ternary graph. Labels will show in the corresponding data point.

Note: User can also use the Layer Contents dialog to add labels. But an extra Z column will be added as well.

ORG-1994 Percent normalized data (0-100) should create Ternary with 0-100 tick labels.
ORG-5515 Improve the error message when Triangulation fails because all points are colinear in Ternary Contour plot.

[edit] Polar Graph Improvements

JIRA Summary Details
ORG-1794, ORG-4522, ORG-6353 Add Show Negative Radius Points in Opposite Quadrant checkbox.
  • Added to the Display tab of the Layer level in the Plot Details dialog.
  • Note this only works when the Radius is set to be Fixed From 0 in the Graph.
  • Removed @YN=1 system variable, which is used to show negative radius in the opposite quadrant.

[edit] Scatter Matrix Improvements

JIRA Summary Details
ORG-4140, ORG-6282, ORG-6843 Redo Scatter Matrix. Including:
  • Output Scatter Matrix in Graph window instead of worksheet.
  • Support Grouping Range and show legend when there is grouping range.
  • Add a Matrix Profile branch in plotting scatter matrix dialog with more options:
    • Show box chart/histogram/nothing in diagonal cells.
    • Show Variable names in Diagonal Cells.
    • Provide Gap control between layers.
    • Show Tick and Label in boundary of scatter matrix.
  • Link X/Y Range so changing one axis can apply to others.
  • Keep Axis settings when changing parameter or performing an auto update.
  • X and Y axis are reversed compared to the old version.

[edit] Data Info and Annotion tool improvements

JIRA Summary Details
ORG-5105 Make Data Information easy to use.
  • Double click in Data Information to open the Data Information Report Settings dialog.
  • Improvements in the Data Information Report Settings dialog:
    • Support window title in Data Information window.
    • Improvements in the Columns and Rows tabs to allow customization of rows and columns in the Data Information window.
    • Support Auto Column width.
    • Alignment support for columns that display in Data Information window.
  • Theme improvements.
    • When current theme is System Default, you make some change and click Apply,the settings should auto saving to <graph>
    • When current theme is <Dataplot>, <Layer> or <Graph>, you make some change and Apply,it auto saving to <Dataplot>, <Layer> or <Graph>.
    • When current theme is <Dataplot>, <Layer> or <Graph> and you load another theme to apply, it should auto save theme to <Dataplot>, <Layer> or <Graph>.
    • When current theme is user defined themes, you make some change and apply,it should auto save theme to <Last used>.
  • Go to Worksheet and Go to Graph context menus in Data Information window.
ORG-6116 More syntax options for Annotation tool.
  • Provide option to hide row information in the Annotation tool.
  • Tab key in Data Annotation mode to toggle which syntax to use, e.g. x, y, z, (x,y), (x,y,z), (x,y)[i], (x,y, z)[i] based on graph type.

[edit] Worksheet

[edit] Floating Graph in Worksheet

Allow placing graphs as floating objects (not embedded in cells) on worksheets for more flexible report creation.

JIRA Summary Details
ORG-1618 Allow Excel like self-contained Graph in Worksheet.
  • Insert Graph button and context menu to add floating Graph in a worksheet.
  • Graph Browser to easily find available Graphs in different folders.
  • Restore Window context menu remove floating graph in worksheet and restore to original independent graph window.
  • Forbid adding graphs to hierarchical result sheet.
  • Support duplicating workbook/sheet with floating graph.
  • Added Object Properties dialog to advanced controls.

[edit] Data Filter

Allow specifying filter conditions on each column of worksheet. Rows that do not meet the filter criteria are hidden and then not considered in plotting or analysis.

JIRA Summary Details
ORG-4862, ORG-4018, ORG-5193, ORG-5348, ORG-6266 Buttons, menus, icons for Data filtering
  • Menus, buttons, context menus to add/remove data filtering, temporary disable filtering and reapply filtering
  • Funnel icon on column header with different coloring to indicate different filtering status.
  • Filter condition in Filter row of worksheet.
  • Statement of filter result on Status bar.
  • Options to ignore hidden rows in Plotting and Data analysis.
ORG-5375 Differnet filtering context menu for Text, Date&Time and Numeric column.
  • Common conditions is provided for Numeric and Date/Time columns.
  • For Text column, checklist will show.
  • Blank and missing row support
ORG-6255, ORG-5668 Custom Filter dialog for advanced users.
  • Readable LT function for data filtering.
  • Save condition for future usage or share with others.
  • Variables and functions can be used in Filtering conditions.
  • Before Condition Script panel for user to run LT script before running the condition.
  • Test button to test the conditions.
ORG-6101 Saving filtering info. in Analysis template.
ORG-6078 Worksheet: Copy Columns to... menu and context menu on columns It copies columns with filter settings.
ORG-6092 LT support for data filtering
  • wks.col.filter=0/1: add/remove filter;
  • wks.col.filter$=: set/get filter query string; (it must set to be advanced filter type)
  • wks.col.filterprescript$=: set/get filter before query script;
  • wks.col.filterx$=: set/get variable to represent the column;
  • wks.col.filterenabled=0/1; enable/disable filter
  • wks.runfilter(): run/reapply filter.
  • wks.hasfilter(): check if current wks has any column filter
  • wks.col.filterstate=; /// -1(no filter), 0(up to date), 1(dirty), 2(error)
ORG=5556 New LT methods for hidden row/column
  • Get number of visible rows/columns
    • wks.VISIBLEROWS=;
    • wks.VISIBLECOLS=;
  • Identify the hidden row/column
  • wks.IsRowHidden(row)=;
  • wks.IsColHidden(col)=;

[edit] Set Column Value/Set Matrix Value Improvements

JIRA Summary Details
ORG-6076 Add Insert Range Variable by Selection and Insert Col Label Cell by Selection sub-menus under Variables menu. Allow user go to worksheet to select data range or column label cell.
ORG-7041 Move all Trigonometric and Hyperbolic functions from the Math sub-menu to a separate sub-menu under F(X) in the Set Col Values/Set Values dialog. F(X): Trigonometric/Hyperbolic menu.
ORG-6973 New Moving average function. movavg(vd, n1, n2). It can be accessed from F(X): Statistics: menu in Set Column Values dialog.
ORG-2947 Add Sample Formulas for Set Matrix Value dialog.

[edit] Other Worksheet changes or Improvements

JIRA Summary Details
ORG-4860 Display statistics information on the Status bar of worksheet.
  • Based on data selected in the worksheet, statistics information is displayed on the right side of the status bar.
  • Supported statistics include: Average, Sum, Count, Min, and Max.
  • Right click on the statistics information to select which statistics are displayed.
ORG-6791 Improve how Origin interprets the date when insufficient data is entered. Added system variable to switch the default behavior.
  • New default is @RMD=1. If a part of date is missing, 1st day of month will be used.
  • Old behavior is @RMD=0. If a part of date is missing, current day of month will be used.

[edit] Gadgets

[edit] Global Vertical Cursor

Improve Vertical Cursor gadget to work on multiple user-selected graphs, allowing tagging across graphs and output x, y values from all curves from all selected graphs.

JIRA Summary Details
ORG-4970, ORG-4971, ORG-6339 Global Vertical Cursor Support
  • Link others graphs to Vertical Cursor gadget.
  • Read/output info. from linked graphs.
  • Support Tagging in all linked graphs.
  • Indicator on upper-right corner of linked graphs.
  • Easy way to move Vertical Cursors to a linked graph. Easy way to go back to graph with Vertical Cursor.
  • Save project file will save the linking.
ORG-6381, ORG-6409, ORG-6429, ORG-6419 Other Vertical Cursor changes
  • Click X= Button to change Reference layer.
  • Context menus in table of Vertical Cursor window for easy manipulation.
  • Hide/Show table on Vertical Cursor window.
  • Add "Line Length" option on Labels and Tags tab.
  • Support None in Label Form and Tag Form.
  • Better Date and Time support.

[edit] Add Straight Line

JIRA Summary Details
ORG-5282 Easy way to add straight lines to a Graph.
  • Graph: Add Straight Line... menu.
  • Easy way to add Vertical and Horizontal lines to a graph.
  • Support Customizing Line.
  • Support Customizing Label.
  • Selectable/Movable controls.

[edit] Digitizer Improvements

JIRA Summary Details
ORG-6215 Digitizer Improvements.
  • Improvements:
    • Now supports importing images from the clipboard.
    • Added Ctrl+W to restore to original size in Pick Points mode.
    • Added Cancel button in the Options dialog.
  • Bug fixes:
    • Digitzer doesn't set Image page correctly.
    • Digitizer should not resample the image. Number of pixels contained in the digitized image should be equal the number contained in the original image.

[edit] Other Gadget Improvements

JIRA Summary Details
ORG-4519 Full LabTalk control of gadget operations.
ORG-6662 Quick Peak gadget: Add warning message when subtracting baseline since it will change source data.
ORG-1352 Combine Pick Peaks Gadget with the Peak Analyzer. A context menu item "Switch to Peak Analyzer" has been added to Quick Peaks gadget, which will open the Peak Analyzer dialog by importing all settings from the Quick Peaks gadget.
ORG-2718 Interpolate gadget: More options for "Fit Limit to" dropdown:
  • Interpolate/Extrapolate to Full Axis Edge
  • Custom

[edit] Analysis

[edit] General Improvements

JIRA Summary Details
ORG-5592 Support Data Identifier other than long name in Report Sheets. In the past, the long name was used as the Data Identifier in the results sheet. When doing analysis on multiple data sets with the same long name, there was no way to distinguish between results.
  • Added a drop-down list at the top level under "Output->Output Settings->Report Tables" branch, named "Dataset Identifier", which allows the user to specify the Range, Book Name, Sheet Name, Short Name, Custom, etc. in the results sheet.
  • Context menu in the results sheet to change Data Identifier.
  • Show Data Identifier in table titles in Report sheet of tools except fitting.
ORG-5481 Non-linear surface fitting for XYZ data using OpenGL. In version 9, XYZ surfaces are directly supported using OpenGL.
ORG-5390 Option to fix intercept for fitLR, firMR, and fitpoly.
ORG-5213 Allow users to pause updating operations. Sometimes it may take time to update operations, support hotkey Ctrl+Shift+P when operations come into updating (where we can see the small update box in the bottom-right corner of the workspace).
  • The hint can be "Hit Ctrl+Shift+P to pause".
  • After the operations are paused, users can click the current yellow Recalculate toolbar button to continue updating.
ORG-5212 "Multiple Plots Use Source Graph Color" should be checked by default. When fitting multiple curves, fitted curve color will match the source curve color by default.
ORG-3509 Calculate X from Y inside a 95% confidence standard deviation. In version 9, Origin supports the estimate the X from Ymeasured (average of some replicates) inside a 95% confidence standard deviation from fitting results, also support estimate the Y from Xmeasured. Note:
  • You can find the control under Find X/Y branch.
  • We provide this control in Linear Fit, Polynomial Fit, and Nonlinear Curve Fit.
  • In Linear Fit, when fit with weight or have fixed parameters, there will be no calculation.
ORG-2189 X-Functions that allow specifying values from Date columns now support the column's Date format. A date selection control is added to select a date from a calendar.

[edit] Fitting & Solving Implicit Functions

Option in NLFit to allow fitting with implicit functions such as ellipse.

JIRA Summary Details
ORG-3378, ORG-5438, ORG-4999, ORG-5522, ORG-4412 Implicit Function Fit in Pro version.
  • Analysis: Fitting: Nonlinear Implicit Curve Fitting menu is added.
  • Iternation Algorithm: Orthogonal Distance Regression is added for Implicit fit.
  • Built-in sample implicit functions.
  • Support Weight for all Variables.
  • Report table is updated to suit for Implicit Fit.
  • Fitting Function Organizer and Fitting Function Builder support to define Implicit Functions.
  • Add a new X-Function nlbegino to perform a LabTalk Implicit Fitting.
ORG-4908 Residual calculation and plotting in Implicit Fitting.
ORG-4454 NLFitSession support function with multiple variables.

[edit] Data Manipulation

JIRA Summary Details
ORG-6697 Pivot Table: Allow user to specify where to output column source information. Column source information could only be output to user defined parameter row in Pivot table in the past. Now such information could be put in Long name, append to column long name, etc.

[edit] Mathematics

JIRA Summary Details
ORG-6114 Add Normalize[0,100] option in the Normalize tool.
ORG-4847 More quantities output for Average Curves. Minumum, Maximum, SD times 2, SD times 3, in 2 XFs: avecurves.OXF and averagexy.OXF.

[edit] Statistics

JIRA Summary Details
ORG-4782 Change OriginPro & Origin Regular mixed tools to be fully functioning in Origin Regular. The current features used to work only in Pro. Now works in regular.
  • more Means Comparison Tests in One-Way ANOVA and Two-Way ANOVA;
  • more quantities in FFT.
  • more quantities in Statistics on Columns.
  • more quantities in Statistics on Rows.
  • more methods in Normality Test.
  • more methods in Peak Finding Settings of replica NLFit.
  • Fit Peaks in Quick Peaks gadget.
ORG-3138 Dixon's Q-Test to Detect Outliers.
ORG-4226 More Dissimilarity Measure methods are supported in Hierarchy Cluster Analysis. Distance types below are newly added:
  • Cosine.
  • Pearson Correlation.
  • Jaccard.

[edit] Signal Processing

JIRA Summary Details
ORG-5692 Better default settings for STFT.
  • Change the default window to Hanning.
  • Change the default output option to "Amplitude in dB".
  • Change preview graph use colormap, instead of gray scale.
  • Pulled STFT be out of the submenu of FFT and put as separate entry under Analysis: Signal Processing.
ORG-639 Support output STFT results to a worksheet. Currently if one wants to plot the result as a waterfall graph, need to convert to worksheet first.
ORG-5827 Output More Quantities for 2D FFT and IFFT.
  • Output log amplitude/power for 2D FFT.
  • Output real and imaginary matrix for 2D IFFT.
  • Support input real+imaginary matrix for 2D FFT and 2D IFFT.
  • Imaginary matrix should be included in input group.
ORG-6106 "Create Image Plot" checkbox is added in Continuous Wavelet dialog. The checkbox will be available when Coefficient Matrix output is checked.


[edit] IIR Filter Design

Support digital filter design, including 5 IIR filters (Butterworth, Chebyshev Type I, Chebyshev Type II, Bessel, and Elliptic) and some FIR filters(optional).

JIRA Summary Details

ORG-4116 ORG-4117 ORG-4118 ORG-5575 ORG-5842

Support digital filter design, including 4 response types (low pass, high pass, band pass, and band stop), and 4 filter methods (Butterworth, Chebyshev Type I, Chebyshev Type II, and Elliptic).
  • 4 response types: low pass, high pass, band pass, and band stop.
  • 4 IIR filter methods: Butterworth, Chebyshev Type I, Chebyshev Type II, and Elliptic.
  • 4 filter representations for the output of the filter design in different worksheets: SOS Matrix, Zeros Poles and Gain, State-Space Form, and Coefficients.
  • IIR filter design and data filter in the same GUI.
  • Support for forward-backward filtering.
  • Preview for filter specification, magnitude and phase response, impulse response, and filter result.
ORG-5371 Support for saving and loading Matlab *.fcf file.
  • Save and load Matlab *.fcf file.
  • Support 3 filter structures for export: SOS Matrix, Coefficients, and State-Space Form.
  • Support 3 export formats: decimal, binary, and hexadecimal.

[edit] Import & Export Improvements

[edit] Import Improvements

JIRA Summary Details
ORG-6343 Support Import pClamp in the 64 bit version of Origin.
ORG-5411 Misunderstanding on Import Cell Formats when importing excel. When importing excel using Excel COM Component, since Import Cell Formats option will not take effect, Origin 9.0 will always uncheck and disable this option in such a case.
ORG-4972 Binary Import 2D Array to support reading column-wise in addition to line-wise.

New control Transpose After Import is added.

impBin2d transpose:=1;

ORG-3771 Support to specify channel names when importing by Script. Add new XF impFileSel xfname:=<impMDF> fname:=myfile.dat trfiles:=<fsel>; after execution, the file structure will be stored in the LabTalk tree variable "fsel".
ORG-3771 Support only imports some variables automatically. Sometimes user just want to import some variables from a lot of files. It needs to do this automatically, but not open the dialog all the time for the user to select specific variables. The updated import routines include:
  • Matlab
  • NITDM
  • pClamp
  • Prism
  • MDF
  • DIADem
ORG-3251 Support Multiple Characters as column separator for import. In Single/Multiple ASCII Import dialog, we add a new entry Delimited - Multiple Characters under File Structure: Data Structure control. When choosing this option, users can enter multiple characters in Multiple Delimiters box as the delimiter.

[edit] Export Improvements

JIRA Summary Details
ORG-5996 Make Export Sound (wav) easier to use.
  • Add auto checkbox to Column (L/R). Auto will set first Y column and second Y column as L and R automatically.
  • Automatically convert data type to Long(4) temporarily before exporting.
  • Improvements to error messages.
ORG-3418 Add a new variable csvsep for CSV export. In ASCII Export dialog, when File Type is set to CSV, the drop-down lists of Separator control will change to be "Comma" and "Semicolon".

[edit] Programming

[edit] Improved Code Builder

Replace Code Builder's editor to be based on the powerful editing component Scintilla, similar to Notepad++.

JIRA Summary Details
ORG-1740 Improve Code Builder's editor to be based on the powerful editing component Scintilla, similar to Notepad++
  • General Environment Configuration (Tools: Options: Environment: General).
    • Load workspace controls: Always, Never, Ask.
    • Auto-save settings.
  • MDI Tabs Configuration (Tools: Options: Environment: MDI Tabs).
    • Enable/disable MDI Tabs.
    • Customize MDI tabs.
  • General Text Editor Configuration (Tools: Options: Text Editor: General).
    • Auto indent.
    • Display indentation guides.
    • Display line numbers.
    • Display selection margin.
    • Enable folding.
    • Enable syntax coloring.
    • Highlight current identifier.
    • Highlight current line.
    • Highlight current scope braces.
    • Highlight folding block.
    • Highlight search result.
    • Highlgiht URL.
    • Tab size.
    • Use DirectWrite.
  • Font and Color Configuration (Tools: Options: Text Editor: General).
  • Added more Hotkeys:
    • Toggle file Read-only attribute hotkey Ctrl + R
    • Open containing folder hotkey Ctrl + Shift + O
    • Open property dialog hotkey Alt + Enter
    • Copy file path hotkey Ctrl + Shift + F
    • Navigate among scope hotkey Alt + Up / Alt + Down
    • Fold All/Expand All hotkeys Ctrl + Alt + - / Ctrl + Alt + =
  • More Useful Windows:
    • Breakpoints
    • Find Results
    • Bookmarks
  • More Useful Tools in Tools Menu:
    • Quick Open Files.
    • Find Symbols.
    • External Tools.
    • Add/remove button to any toolbars (Tools: Customize: Button Groups).
  • Improved Searching:
    • Make the Find in Files tool run in a separate thread.
    • Search via the search combo (in the toolbar) will highlight the results.
    • Support searching in the Output window and the Find Results window.
    • Show animation on status bar to indicate the searching progress.
  • Improved Navigating/Browsing through files:
    • List the most recent opened file at the top of window list.
    • Use new Windows dialog (Window: Windows).
    • IDE navigator through opened files (Ctrl + Tab).
    • Switch quickly between related files by hotkey.
    • Support smart opening of files.
  • Other features:
    • Edit: Go to row to quickly go to a row.
    • Edit: Auto-Completion to open a drop list of options to pick from when typing.
    • Debug: Run to Cursor support.
    • Enable quickly add breakpoint by clicking the space in front of the code line.

[edit] Code Improvements

JIRA Summary Details
ORG-6653 More options for substitution
  • Support @ option for page level should support Graph window, e.g. @PL, @PC, @PC1
  • Substitution to denote PE path @P
ORG-6210 Support range -wz to give z column range of plotted 3D graph E.g. range -wz rWz =1 to get first 3d xyz plot's Z values
ORG-5788 Provide OC and LT function for Lambert's W function
  • LT function
w=lambertW(double x, int branch=0, int offset=0)

  • OC function
int lambertW(const double x, double &w, const int branch=0, const bool offset=false)

  • User can access it from F(x): NAG Special: menu of Set Col Values/Set Values dialog.
ORG-5634 LT command for listing and delete duplicate datasets
list -sr; /// list same( duplicate ) datasets 
del -sr; /// delete same( duplicate ) datasets

ORG-5552 LT command to read and write offset values for a dataplot
get %c -sx xx;
get %c -sy yy;
set %c -sx 10;
set %c -sy 20;

ORG-5530 range -w support multiple ranges declare E.g.
newbook;
col(1) = data(1,32);
col(2) = col(1);
plotxy iy:=(1,2);
dataset begin = {2, 15}; dataset end = {4, 19}; 
mks ob:=begin oe:=end mode:=1; 
range -w aa = %C;
type %(aa); //Get [Book1]Sheet1!(B[3:5],B[16:20])

ORG-5449 Support C style union
union Unix {
	BOOL	bValue;
	int		nVal;
};
void test_union()
{
 
	Unix uu;
	uu.bValue = 10;
	out_int("uu.nVal = ", uu.nVal);
}

ORG-5369 Option not to hide whole branch in X-Function GetN dialog if first variable is hidden In the past, if a variable was the first variable in a G style branch and was hidden, the whole branch would be hidden. Added an option so that the branch will be still visible and only that variable is hidden.
ORG-5275 Set Column Values with a Dataset In 9.0, user can generate a dataset of certain size with a formula and some before formula script, and later assign this dataset to a certain column. The syntax is:

dataset.setvalues("Formula", "Before formula script", "From", "To")

ORG-5214 LT access on worksheet comment layer.comments$
ORG-5046 Plotting XFs like plotxy need option to hide graph The option is added in the following XFs:
  • plotbylabel.OXF
  • plotgroup.OXF
  • plotm.OXF
  • plotms.OXF
  • plotmyaxes.OXF
  • plotstack.OXF
  • plotvm.OXF
  • plotxy.OXF
  • plotxyz.OXF
ORG-4452 LT getn @BBcolumn should support to browse column not in current sheet Column Browser open from option @BBcolumn using LT getn command support browse from other sheet. This is controlled by ststem variable @eld(default is 1).
ORG-4440 Support drag & drop in vsflex gird
ORG-4395 Support defining local variable name with %( ) substitution Following script will work in 9.0
string str1$ = var;
int My%(str1$) = 4; //Declare integer "Myvar"

ORG-4254 Add/load OP file from LT should support file name without _32/_64 For op file, we had to specify the full op file name, such as run.addoc(%yabc_32.op) or run.addoc(%yabc_64.op) in the past.

We should support run.addOC(%yabc.op) as well, which means that we should automatically add _32/_64 to search the op file.

Same to run.LoadOC().

ORG-2998 Improvement on Layer.CMap object Following options are added to Layer.CMap ojbect,
  • layer.cmap.zAbove: The Z value exceeds the nth Z level, where n is numColors.
  • layer.cmap.setZLevels(dataset, n): set the z level values, starting from the nth level. Restriction: 1. The size of dataset must be <=numColors+1; 2. (size of dataset + n) must be <=numColors+1; 3. The dataset must be strictly increasing.
  • layer.cmap.insert(n): Insert a level value between the nth level and the previous level, where n is 1 to numColors+1.
  • layer.cmap.delete(n): Delete the nth level value, where n is 1 to numColors

[edit] Graph Animation

Create animations (AVI, GIF) of graph windows, where graph is animated either manually or by using LabTalk scripts or OC programming.

JIRA Summary Details
ORG-4928 Video Builder to create Videos by GUI.
  • Video Settings dialog to set Video height & width, Frames per second, and compression.
  • Interactive way to add Graphs frames.
ORG-4927 OriginC support of Video recording. Refer to help file for examples. VideoWriter class.
ORG-4929 LabTalk support of Video recording. vw object. Please refer to the help file for examples.

[edit] Graph Export and OLE

JIRA Summary Details
ORG-6644 Option to show title when sending graphs to Powerpoint. A Title mode and Custom Title String control is added in the Send graph to PPT dialog:
  • Window Short Name: %H.
  • Window Long Name: %(%H, @PL), please check correct notation.
  • Window Short + Long Name: %H - %(%H, @PL).
  • Window Path: %(%H,@P), not sure if that is a valid notation.
ORG-6774 Improve default settings of PDF export to reduce file size. Set Color Images and Monochrome Images dropdown list is set to Flate as default in Image Settings: PDF Options: Data Compression: node.
ORG-4708 File Name improvement in export tool.
  • Support keyword combination. General to other export tools.
  • Add <sheet name> option for File Name dropdown in Export Multipage PDF File tool.

[edit] Toolbars and Menus

JIRA Summary Details
ORG-4074, ORG-4060 Toolbar Options button at the end of each toolbar to Add or Remove buttons. It provides an easy to turn on/off toolbar buttons.
ORG-1727 Improve both the Column/Row/Cell/Page/Plot and Context menus.
ORG-3464 Function Key F5 to refresh a window. Click F5 to refresh a window.
ORG-4690 Hotkey Alt+Enter to open the Window Properties dialog. This provides a quicker way to open the Window Properties dialog for user to enter window long name, etc.
ORG-5270 Add Format: Fit Page to Layers... menu There is Graph: Fit Page to Layers... menu. Now added it to Format menu too since there are similar menus there.
ORG-2792 Add Extract to the Layer Context menu.
ORG-4925 Status bar customizations with context menu.
  • Support ALT+drag on Status bar to move display orders, except the leftmost status information.
  • Click to turn on/off some status bar information.
ORG-5269 Create "Merge Cells" menu with Shortcut Key under Format menu.
ORG-1653 Moved Single Peak Fit menu from Analysis: Signal Processing: to Analysis: Fitting:
ORG-6232 Hotkey X+Mouse Wheel downward should shift plot to the left. It used to shift the plot to the right.

[edit] Miscellaneous

JIRA Summary Details
ORG-2840, ORG-3938, ORG-4220 Redesigned the Transfer User Files dialog.
  • Change File types dropdown list into checkboxes.
  • Export button to export files planning to transfer as opx file to share with others.
  • Show Newer Files only checkbox on Source file panel to only display files newer then those in current UFF.
  • Support transferring custom files, e.g. default.xml, CustomColors.ini, ParamTab.ini, ImportMenu.xml.
  • Specified Folder in Transfer User Files should support recursive so subfolders can be shown.
ORG-5289 Allow group sharing filer to be non-UNC path. This way, Cloud service such as Dropbox can be used for group folder sharing.
ORG-4782 Change Pro&Regular mixed tools to be fully Regular. Pro-only features in tools listed below are available in Regular version now:
  • Means Comparison Tests for One-Way and Two-Way ANOVA.
  • Quantities in FFT.
  • Quantities in Statistics on Columns.
  • Quantities in Statistics on Rows.
  • Methods in Normality Test.
  • Methods in Peak Finding Settings of replica NLFit.
  • Methods in Peak Finding Settings in Quick Peaks gadget.
  • Peak Marker in Multiple Peak Fit.

[edit] Licensing

JIRA Summary Details
ORG-1304 Running concurrent versions of Origin on the same Computer with the same SN should count as a single license. e.g. run 9.0, 8.6, etc. with same SN, only 1 license will be checked out.