ReleaseNotes:Features that were changed in 8.5.1

From OriginLab Wiki

Jump to: navigation, search


Note:

  • Red items are bugs reported from customers. Black items are bugs found inhouse.


Contents

[edit] Gadgets

JIRA Summary Description
ORG-2116 Quick Peaks Gadget The Quick Peaks gadget provides a quick and interactive way to perform peak analysis on data plotted in a graph.
  • More Baseline calculation controls.
  • Use local baseline in ROI by default.
  • Support calculating area.
  • Support Fit Peaks (Pro only feature).
Digitizer ORG-1836 With the Digitizer, you can easily digitize images of graphs such as photocopied, faxed, or scanned images.
  • Support rotated image.
  • Support Date/Time axis.
  • Support adding Labels in picked points.
  • Support digitizing multiple curves.
ORG-2088 Catch changes in DigiData worksheet and update in Image.
Cluster Gadget ORG-1749 The Cluster Gadget performs simple statistics on a region of interest (ROI) in a graph. The gadget can also be used to edit, clear, or mask data points.
  • Support Data Manipulation and Statistics.
  • Support both Inner and Outer region of interest. (Outer points are not calculated by default).
ORG-1755 Support turning on/off Real-time calculation.
ORG-1845 Statistics Gadget The Statistics Gadget performs simple descriptive statistics on a specified region (ROI) of a data plot.
  • Support specifying labels' positions on statistic lines.
  • Support statistics on multiple plots together in the same graph layer.
ORG-2317 Rise Time Gadget The Rise Time Gadget in Origin provides an intuitive and interactive way to analyze rise/fall time of a signal plotted in a graph.
  • Support independent methods to determine high and low levels separately.
ORG-1592 All gadget tools (except Quick Fit) open as tabbed dialog. For ease of use, gadget controls now appear in tabs instead of in a tree structure.
ROI box position controls ORG-1930 Support locking ROI box position to prevent unintentional movement of the ROI. Save the ROI box position in a theme file to always open the gadget in the same position.
ORG-2342 New Move ROI to context menu item for moving gadget onto data selector position.
ORG-1475 Hot keys for toggling between handles of the ROI box. Press H key to select the left handle if ROI box is not yet selected. Use Tab/Home/End keys to toggle. Use Left/Right key to move ROI box position.
Improvements on multiple gadgets in one graph. ORG-2227 Different color now used for each ROI box.
ORG-2230 Select one gadget, then press Tab key to toggle through gadgets.

[edit] Analysis

JIRA Summary Description
Multiple Peak Fit improvements ORG-1527 New X-function dialog for multiple peaks fit
ORG-1532 Support opening NLFit dialog to customize parameters
ORG-1933 Provide option to perform Multiple Peak Fit using peaks found with Quick Peaks gadget.
ImprovementsSurface Fit ORG-1479 Support multiple peaks fit in surface fit.
ORG-402 Support showing XYZ surface plot as fitted curve in 3D graphs.
NLFit dialog Improvements. ORG-515 Copy/Paste Whole Column context menu item in Parameters dialog of NLFit and Peak Analyzer now operates only on visible rows.
ORG-938 Provide option to set Date/Time values as parameters in NLFit.
ORG-1169 Display source data range on NLFit Parameter Tab.
ORG-2182 Move Find X/Y or Find Z control out of Advanced tab, add to Settings tab.
ORG-2352 Show Constant values in the Code page of NLFit dialog and report sheet.
ORG-2368 Improved Confidence Band and Prediction Band labels.
ORG-2468 For Replica Fit, Plot Individual Curve is enabled by default.
Fitting Function Improvements/Changes ORG-1706 Compute FWHM for more peak functions: Lorentz, Laplace, Logistpk, and Voigt.
ORG-2090 Change the fitting function name from Harris to FarazdaghiHarris.
ORG-2330 Better parameter initialization code for BoltzIV gmax parameter value.
ORG-1669 Michaelis-Menten function added as built-in function in Growth/Sigmoidal and Pharmacology category.
Peak Analyzer ORG-793 Move Fit Control node from Fit Peaks page to Fit Control tab in Fit Control dialog.
ORG-2504 Default value of Max Number of Iterations changed to 200; default value of Tolerance changed to 1E-6.
ORG-247 Peak Labels use Date format if Date X values.
ORG-354 Plot Integral curve in Integrate tool Support plotting integral curve to source graph from Integrate dialog.
ORG-1227 Output result improvements in FFT tools Support output results with Units if source data includes Units.
ORG-1527 Add a new X-Function fitMR Perform multiple linear regression from script.
ORG-1982 Removed Linear Fit with X Error from Analysis menu. Linear Fit with X Error has been temporarily removed from the Analysis menu due to conflicting interpretations of fitting methods.
ORG-2049 Add Treat Numbers As Double checkbox in Fitting Function Builder and Fitting Function Organizer dialogs. When defining an Origin C-type fitting function, all numbers are treated as double type if the checkbox is selected.
Masking Improvment ORG-1672 Add Masking Menu to Data Menu in Graphs
ORG-1846 Improve the speed of masking points on graph for large data.
ORG-1673 Mask selector now includes 3 shapes: 1. mask by index; 2. mask by region, rectangle shape; 3. mask by region, free shape. Use the Space bar to toggle between these shapes.
ORG-2123 Data Manipulation Improvements Subtract Straight Line (subtract_line) supports double-clicking a point to subtract a line at the Y value.
ORG-88 Improve Batch Processing Output Report control Customized data information to show in result sheet when doing batch processing with multiple data files.
ORG-1977 Add Select from Worksheet flyout menu for more input data types in X-function dialogs. Select from Worksheet, Select Columns, and Reset previously appeared only on the right-triangle flyout menu for XYRange and XYZRange variables.

These options are now available for other data types, such as Range, Column, Vector, and Vector Complex.

[edit] Import and Export

JIRA Summary Description
Graph Export Improvements ORG-67 EPS now exports correctly after duplicating the legend on computer without East Asian Language package.
ORG-580
  • Add a radio group in ExpGraph dialog for supporting raster embedding.
  • EPS and PDF transparency added.
ORG-778
  • Raster compression checkbox (checked by default) added to the bottom of EPS Options.
  • Better compression for EPS export.
Third-party file formats added ORG-1247 Support the TDMS file created by LabView 2009 SP1.
ORG-1397 Support for importing Graphpad Prism files.
ORG-441 mzML and mzXML file support.
ORG-1517 In pCLAMP import, show start time of sweeps in Parameters row when Time column is shown. Add Time Column checkbox added in pClamp Import dialog. When checked, start time of sweeps is imported into Start Time row in worksheet.
TDM, TDMS file Import Improvements ORG-2363 Support importing all layers of a single file into one worksheet.
ORG-2619 Support Import Channel Properties options to speed up importing.
ORG-1448 Add Custom Time Format option in Import Wizard and Import ASCII dialogue. Users can now import data with a custom Time format. Custom-formatted time data is now imported as data instead of text.
ORG-1737 Control when to run LabTalk Script after multiple data import in Import Wizard. Two radio buttons added on Import Wizard's Advanced Options Page.
  • Run Script after each file imported
  • Run Script after all files imported
ORG-1762 Remove leading Zeros from Numbers checkbox on by default. This is checked by default now in Import Wizard and ASCII import.
ORG-1832 Drag&Drop Exclusion column added in Import Filter Manager. Import Filter Manager (in the Tools menu) controls which data type can be imported into Origin via drag and drop. For each data type, users can specify which data extension to exclude from drag and drop.
ORG-1848 Turn on/off thumbnails when importing into matrix. When importing ascii data into a matrix, users can use the Add Sparklines combo box to turn thumbnails on or off.
ORG-1993 Import ASCII will always use system default or default settings unless there is a theme saved in the Sheet. In the past, the Import ASCII dialog opened with the last used settings and this often confused users. The dialog now opens as follows:
  • By default, the dialog always opens with system default settings.
  • If there is a customized import theme which the user has saved as <default>, it will be used.
  • If there are import settings saved in the sheet, the import dialog will open with the sheet's import settings.
ORG-2353 Copying and pasting data will remove leading Spaces when they are used as delimiters. Space delimiters have been supported since 8.0. If a user's data has leading spaces, then using a space delimiter will produce an empty first column. Leading spaces are now trimmed before import.

[edit] Database Import

JIRA Summary Description
SQL Editor for Database Import ORG-1142 Set ADO import date format in Options/Numeric Format dialog.
ORG-1179
  • ADO Dialog has been re-designed to be more flexible and more suitable for DB users.
  • A new dialog Query Editor has been added for users who prefer to work directly within the SQL environment.

[edit] Graphing

JIRA Summary Description
ORG-1380 Improved Color Support ORG-1381 Palette button on the Style toolbar for easy application of color palettes.
ORG-1591 Origin now supports Undo after applying a color palette to a plot.
ORG-755 The Plot Details Colormap Fill… dialog now includes support for flipping and stretching palettes.

Check or clear the Flip Palette or Stretch to Full Range check boxes to activate or deactivate these functions.

ORG-1434 Fill Color button on Style toolbar enabled for Fill Area plot.
ORG-2516 Fill Color button on Style toolbar enabled for scatter plot.

Create a scatter plot. Click once on the plot to enable the Fill Color (paint can) button. In previous versions, the Fill Color button was not available for scatter plots.

ORG-1383 Apply palette to thumbnail in image and data view

Create a matrix, fill with values, and show image thumbnails. Palette button is enabled. Switch to Data view. Palette button remains enabled.

ORG-437 Data Plot Modifier column can be anywhere in the worksheet.
ORG-2041 @UCI system variable added to control whether to update colormap data immediately after changing the scale settings from a LabTalk script.
ORG-1211 Set Levels and Set Fill Colors added to Colormap context menu for contour graphs.
ORG-731 Colormap is supported in the Save format as theme dialog.
ORG-9 New Layer Contents dialog ORG-1837 More dataset information in both the Left and Right panels, along with better nested sorting (e.g., by Long Name, Book, sheet).
ORG-2046 Status column in left panel for sorting. Indicates whether the column data is Raw or Locked by Analysis.
ORG-2046 Matrices/Worksheets associated with graph selection in dropdown menu for filtering datasets related to a graph.
ORG-1879 Plot Type button above the => button for selecting plot type when adding layer content.
ORG-1837 In the Graph menu, items under Add Plot to Layer (e.g., Line…, Scatter…) now open the Layer Contents dialog when no data is selected.
ORG-1986 Layer Contents dialog displays user-defined parameter names.
ORG-715 Plot Details Improvements ORG-746 On the Group tab, the Increment Details “…” buttons now remain visible for improved usability.
ORG-2071 Save and load Increment List context menu on Group tab.
ORG-2071 Support editing multiple items in Increment Editor.
ORG-2071 Support Load Palette in Increment Editor.
ORG-1451 New Format String combo box on Label tab with examples to help user customize labels.
ORG-1605 Change Major Levels for Log scale type in Set Levels dialog on Colormap tab.
ORG-798 Support switching between 3D Scatter and 3D Wire Frame in Plot Details dialog.
Axis Dialog Improvements ORG-941 Specify major and minor Tick Locations by Dataset
ORG-2195 Custom Date/Time format support on Tick Labels tab.
Save Template as dialog improvements. ORG-1388 Show existing templates in Template Name list in Save Template As dialog.
ORG-1483 Pop up confirmation dialog when trying to save built-in template.
ORG-54 Polar Graph Improvements ORG-1811 Angular error bars are now drawn as arcs, and are drawn from the centers of large symbols.
ORG-1928 Drop lines drop to center of polar plot.
Histogram Improvements ORG-1835 Add Go to Bin Worksheet button on Data tab of Plot Details dialog for histograms.
ORG-1941 Support setting number of bins in Plot Details dialog for histograms.
Context menu of layer icon ORG-671 Add Set Active Layer by Layer Icon Only to Graph menu, page context menu, and layer icon context menu.
ORG-866 Add Hide Other Layers to layer icon context menu.
ORG-2439 Add Show Active Layer Only to layer icon context menu and page context menu.
ORG-2439 In View menu, under Show, change All Layers to Active Layer Only.
ORG-1413 Correct the font size of text in Orgin Graphs. When pasting graphs into MS Word, the font size of the text created in a graph window displayed differently from text created in Word. Origin now includes a Convert to Standard Font Size menu selection to fix font size problems in previously existing project files. For newly created graphs, this compatibility issue does not exist.)
ORG-1480 Column plot template with Y=0 line in graph. Template for column chart with positive & negative bars adds bottom X axis and a line at Y=0.
ORG-1866 Box Chart Improvements Allow Meanline Only Box chart.
ORG-1560 Improvement on Data Selector Support keyboard navigation for Data Selector.
Error bar improvements ORG-2323 Add an option in plotxy X-Function dialog to support plotting Y error.
ORG-582 Error bar now could plot as Line or Fill through Plot Detail control.
ORG-2065 link support in graphs. Links were previously supported only in worksheet cells, but are now also supported in graph text labels. Also support standard visual effects for links in text labels. Link types supported:
  • Internal links for opening a specified range of column data (e.g., range://[book1]Sheet2, or range://[book1]sheet2!col(temp).
  • External links for opening in browsers (e.g., http://www.originlab.com).
  • Help Links (e.g., help://TUTORIAL.CHM/Tutorial/Import_Wizard.html
ORG-1925 Legend improvements: ORG-2261 Add Verbatim checkbox to text label dialog.
ORG-506 Use long name when available in Enhanced legend.
ORG-939 More graph theme support: Support bin size in theme for Histogram and Box plot.
ORG-2443 Rename the Score Method labels for Plotting Plot and Q-Q Plot. Rename"Renard" and "Var der Waerden" to "Benard" and "Van der Waerden".
ORG-2347 New tool Fit Page to Layer to remove margin in a page. Use this tool to expand a page to encompass all layers. Users may adjust height, width, both height and width, or border width.
ORG-2344 In Graph menu, rename Maximum Layer menu selection to Fit Layer to Graph. The Fit Layer to Graph menu selection appears under the Graph menu. The status bar text for this item is "Change the active layer size to fit the whole page".
ORG-2206 Add Create Spline/B-Spline/Bezier/Step xxx Data context menu for dataplot in graph. For line or line+symbol plots with B-spline/Bezier/Step line connections, choose this context menu to create a worksheet of the data from the curve.

[edit] Data Manipulation

JIRA Summary Description
ORG-1052 Wcopy X-Function improvements Added a check box for specifying whether to copy a worksheet script to a target worksheet.

[edit] Programming

JIRA Summary Description
ORG-744 LabTalk Error Message for Syntax Error has been improved. Improve LabTalk error checking for mismatching parenthesis, and operand missing.
ORG-1329 System variable __HEADER$ now have no limitation for holding lines. System variable __HEADER$ can only hold 99 lines of the header information after ASCII file importation in previous versions. Now, the limitation has been extended to 999 lines.
ORG-1665 Added system variable @SDD to indicate the meaning of @SD. @SDD = 0(default) indicate @SD means significant digits for type $() output, while @SDD = 1 indicate @SD means number of decimal digits.
ORG-1829 Added a method range.maxrows to get the the number of data in loose dataset. Added maxrows property to dataset so user can use maxrows to get the number of data in the dataset range. For example,
dataset ds = {0.1, 0.2, 0.3, 0.4, 0.5};
range rr = [??]!ds;
rr.nrows=; //will return 10
rr.maxrows=; //will return 5

ORG-1991 Allow script control of contour labels. Provides script access to the contour label options in the Plot Details dialog box.

Following are available properties:

layer.plotn.contourlabels.size
layer.plotn.contourlabels.font
layer.plotn.contourlabels.color
layer.plotn.contourlabels.whiteout
layer.plotn.contourlabels.bold
layer.plotn.contourlabels.italic
layer.plotn.contourlabels.underline
layer.plotn.contourlabels.minarea
layer.plotn.numericformats.prefix
layer.plotn.numericformats.suffix
layer.plotn.numericformats.subformat
layer.plotn.numericformats.divideby
layer.plotn.numericformats.digimode
layer.plotn.numericformats.digits

Note: Replace n with the data list number of the contour plot you want to edit.

ORG-2033 Allow script to set data label to bold, italic, and underline. -qb value: Set the data label to bold;

-qi value: Set the data label to italic;
-qu value: Set the data label to underline;

ORG-2063 Added system variable @GAS to control if Generate Script should dump all scripts about every X-function variable(except hidden) or not. @GAS = 1(default @GAS = 0) indicate to dump all scripts about every X-function variable(except hidden).
ORG-2073 Labtalk $ substitution format custom display support. Since 8.5.1, we support custom date/time display in Labtalk $ substitution. For example, you can use $(x, D yyyy'.'MM'.'dd) or $(x, Dyyyy'.'MM'.'dd).
ORG-2216 re-define column level range using sheet level range. After defining a sheet level range variable, this range variable can be used to define column level range variable now. For example,
range aa=Sheet1!; 
range rCol = aa!col(b);

ORG-2259 Add OC and LT access for the Creation index for a layer. Provide OC and LT method to access the creation index for a layer. For OC, see Layer::GetCreationIndex(). For LT, you can use layer.cindex or page.findlayer(cIndex).
ORG-2296 Provide a method doc -xw excelBookName to convert Internal Excel Worksheet into Origin Worksheet. LabTalk command doc -xw <Excelbookname> will convert the Excel internal book with the supplied name into Origin workbook. If the name is not supplied, then all the internal Excel books in the project will be converted.
ORG-2301 Want option to turn off built-in progress bar. @PBN = 1(default @PBN = 0) will turn off built-in progress bar.
ORG-2360 support reimport for file with the user defined format by OC. Since 8.5.1, Re-Import supports the user define data format file. See this Example
ORG-2485 Added system variable @SCW. When comparing raw strings using equals, @SCW = 1(default) means check wildcard and do string match, else @SCW = 0 will do string comparision. When use the == and != operators to compare two strings, @SCW = 1(default) means check wildcard and do string match, else @SCW = 0 will do string comparison.
ORG-2496 Added system variable @PST to support pasting string contains space into one cell. @PST(default is 0) controls whether use SPACE as separator or not when pasting string into worksheet. If you set @PST = 1, then copy a string contains white spaces will be pasted into one cell in worksheet, otherwise, it will be separated and pasted into multiple cells(column across).
ORG-2506 Add error checking when delete a file from LabTalk script. Since 8.5.1, LabTalk command del -f will dump error message to Script Window if fails to delete a file.
ORG-2509 Range Input to X-function should accept arbitrary range pairs. Support multiple range variable as input range for X-Function. For example,
range r1 = [Book1]1!2;
range r2 = [Book1]2!2;
corrcoef irng:=(r1,r2); //This works since 8.5.1.

ORG-2526 Added a method run.notes(NotesWindowName) to run the text in Notes window line by line. If user has LabTalk script in Notes window, then use run.notes(NotesWindowName) can run the text in the Notes Window line by line.
ORG-2526 Added an option -cnw to window command to support wildcard for Notes window name. It's the extension of -cn option. Syntax: -cnw winName

Close the winName notes window without prompting. This command supports wildcard. For example:

win -cnw Notes*;

ORG-2526 Supports LT substitution in URL display text. For example, if user enter "http://www.originlab.com/ %(str$)" in worksheet cell, then it will display as Homepage where str$="Homepage".
ORG-2526 Added a system variable @SCL to support LT substitution in column label rows. @SCL(default is 0) controls LT substitution in column label rows.
  • @SCL = 1 to allow long name
  • @SCL = 4 to allow comments
  • @SCL = 5 to allow both long name and comments field
ORG-2575 Added a method wks.SetAsLabel to support LabTalk access for Set as LongName, Unit, etc. Syntax: wks.SetAsLabel(type, row, label, append)

Make one row as Long Name, Unit, Comment, or Parameters, etc.

  • type = Label type, you can use L, C, U, P, etc.
  • row = Row index to set as label. Note: Value -1 means the selected row, and if call this method for selected row, the the selected row will be removed after call.
  • label = 0 indicates label row, 1 indicates data row.
  • append = 1 means append to original content, 0 means replace original content. This only works for Long Name and Comments.
ORG-2641 Support range as argument for "mark -w1", "mark -w1u", "mark -wd" and "mark -wdu". In previous versions, the LabTalk commands "mark -w1" etc. require that the data cells are already highlighted in worksheet. Since 8.5.1, we also support range as argument. For example,
range aa=1;
range bb=1[1:32];
mark -wd aa;
mark -wd aa[1:32];
mark -wd bb;

ORG-2600 Dialog builder samples are re-included to the product. Now that we no longer have Developer Kit, and everyone can create dialogs and access them programmatically from Origin C, so we just include Dialog Builder samples into product. You can find these samples in exe\Samples\Dialog Builder folder.
ORG-2659 Added system string variable __LASTOGS$ to hold the last execute OGS file. After execute an OGS file, user may use this system string variable __LASTOGS$ to make a further usage of the OGS file. Note: This variable is readonly.
Added string method to get length of string: str.Len() Previous versions support only str.getlength(). Since 8.5.1, user can use str.Len() to get the length of a string.
ORG-2425 Add Image Files support. If user enter file://path syntax in worksheet cell and the file extension is an image file, then image will show in the cell.

The following code will fill a worksheet column 2 with wallpaper images:

wks.ncols=2;
dlgPath init:="c:\windows\web\wallpaper\";
string fn$, fname$;
findfiles f:=fns$ e:="*.*"; // findFiles will default to get from path$
int n = fns.GetNumTokens(CRLF);
for(int ii = 1; ii<=n; ii++)
{
	fname$ = fns.GetToken(ii, CRLF)$;
	wcol(1)[ii]$=fname.GetFileName()$;
	wcol(2)[ii]$="file://"+fname$;
}

[edit] Project Explorer (PE)

JIRA Summary Description
ORG-1567 Removed View Windows in Active Folders & Subfolders from Project Explorer context menu. In 8.5.1, the option to View Windows in Active Folders & Subfolders has been removed from the Project Explorer context menu. This option was confusing for users because it displayed more than just the windows in the active folder. View None and View Windows in Active Folder are the only two options that remain in the View category of the Project Explorer context menu.
ORG-2403 Add Go to Original Folder context menu in shortcut window title. Users can create shortcuts in workbooks, matrices, graphs, or layout windows to folders in Project Explorer. A Go to Original Folder context menu selection has been added, allowing users to easily navigate to the actual folder from a shortcut window title.
ORG-2511 Support showing long and short names for all view modes in Project Explorer. In Project Explorer, when the Show Long and Short Name context menu item is checked, both long and short names are displayed. This option was previously available only in the Details view mode, but is now available for Large Icon, Small Icon, List, and Details.

[edit] Workbook

JIRA Summary Description
ORG-296 Stack and Unstack Columns Improvements ORG-1882 Improved Grouping Identifiers.
ORG-1892 Hints update when checking and clearing checkboxes in Stack Columns dialog.
ORG-2122 Stack into Subgroups control improvements.
ORG-1918 Users can now specify a data column's long name.
ORG-1917 Unstack Column improvements.
ORG-2581 Custom option in Put Grouping Info to dropdown menu, allowing users to enter custom label row characters.
ORG-2580 Stack Columns supports single column label row characters in Group Identifier.
Pivot Table Improvements ORG-2025 Support adding extra columns and rows with specified settings in Pivot Table.
ORG-2052 Support combining small values in columns or rows into one column or row.
ORG-2026 Support sorting output by row totals in Pivot Table
ORG-2150 Some re-organization in Pivot Table dialog.
ORG-2210 Column source and data source names no longer lost in output.
ORG-2237 Labels and hints improved in Pivot Table dialog.
URL link improvements ORG-2426 Display text as part of URL in worksheet cells. A space after a URL can be followed by plain text. Example:
http://www.originlab.com Click Me!

ORG-2416 Support URLs in Column Labels. Previously, users could put URLs only in the data area of a worksheet. Now users can put URLs in column label areas (e.g., Comments) as well. To edit a URL, mouse over the URL and hold down the left button for about two seconds before releasing.
ORG-1488 Column Properties dialog supports custom Time format. Origin now supports Custom Time Format, allowing users to modfy the format of their time data. Custom-formatted time data is interpreted as data instead of text.
ORG-480 Workbook Usability Improvements ORG-1570 Highlight selected range's row header and column header as in MS Excel.
ORG-1076 Add worksheet dividers.
ORG-1571 Support hiding and unhiding columns and rows.
ORG-2040 Make Add user defined parameters row easier.
ORG-2040 Add Edit... to open column label rows dialog.
ORG-2043 Add Append to Long Name in context menu.
ORG-1014 Reverse data order in columns or ranges. Users can highlight multiple columns and reverse the order of their data. This also applies to a range highlighted in a workbook.
Convert worksheet to XYZ Columns or Matrix improvements ORG-1112
  • When converting matrix data to XYZ columns, empty rows at the bottom of the worksheet are trimmed to prevent mismatches in the XYZ columns.
  • Worksheet to Matrix conversion always trims empty columns at the rightmost side of data.
ORG-1515 When converting YZ data into a matrix, the sampling intervals in Y data are used to decide X mapping in the result matrix.
ORG-2294
  • XYZ Gridding selection in Convert to Matrix menu supports output to virtual matrix.
  • XYZ Log Gridding menu added to Convert to Matrix menu to convert data with XY in log scale.
ORG-1880 Upon Changes in Range supports multiple ranges in Worksheet Script dialog. Support standard range notations, and support entering multiple data ranges in the edit box so changes in multiple columns trigger the script. The multiple ranges can be separated by commas (e.g., A, B, C, 1:end).
ORG-2024 No scientific conversion if Display is set to 1,000. Origin ignores upper threshold settings on the Numeric Format tab of the Options dialog (available under Tools) and correctly displays large numbers.
ORG-1995 Convert a Fraction to a Decimal sample in Set Column Values dialog. In the Set Column Values dialog, choose Formula, then Load Sample, and then click on Convert a Fraction to a Decimal to see how to define an LT Function and call it.
ORG-2243 Non-matchable double quotes not allowed in Column Long Name. Previously, if a user had a column long name such as “X, analysis failed because Origin was unable to resolve the range string. Origin therefore no longer allows non-matchable double quotes in long names, and resolves this problem by automatically removing them.
ORG-2429 Link to embedded graph opens book with sheet containing embedded graph when link is double-clicked. After analysis, an embedded graph appears in the hierarchy result sheet. If a user embeds this graph into a workbook in other folders, and then double-clicks the embedded graph, Origin takes the user back to the hierarchy result sheet where the original embedded graph is located.
ORG-2436 Improvements to Find and Replace for text or strings in multiple sheets, books, or folders.
  • Look in dropdown list added to Find dialog so user can find text or strings in other workbooks, sheets, or folders.
  • When the Find or Replace button is clicked, the cursor goes to the next occurrence regardless of whether it is in an active sheet.
  • Output message for Replace All now says "N occurrences of XXX were replaced by YYY".
ORG-1632 New X-Function for creating a virtual matrix. Virtual matrices were previously created only when plotting 3D graphs. Origin now includes the w2vm x-function, which can be used to create virtual matrices in the Layer Contents dialog and other places where a virtual matrix might be used.
ORG-1077 Changes to text label creation in workbooks
  • When users right-click the gray area to the right of the column label region, or in the gap above the worksheet (gap size is set on the Size tab of the Worksheet Properties dialog) to add a text label, the label is now attached to the page by default and always shows.
  • When users right-click the gray area to the right of the data region (below the column label region) to add a text label, the text is attached to Layer and Scales by default. The label now scrolls with the data and hides when the data row reaches the header region.

[edit] Matrix

JIRA Summary Description
ORG-1695 X-function mstats now handles gray image/non-double type matrix. The mstats X-function is used to get statistics (mean, sd, n, max, min, sum, missing (number of missing values))on data in a matrix.
mstats;
mstats.=

Previously, mstats could not handle image/non-double type matrices. This type of matrix is now supported.

ORG-2016 Add Trim Missing Values checkbox to Convert Matrix to Worksheet dialog. With this checked, missing values will be trimmed in the output Z column when converting matrix to XYZ columns.

[edit] Statistics

JIRA Summary Description
ORG-1940 Allow setting Number of Bins in Frequency Counts dialog.

Previously, the Frequency Counts dialog allowed users to set only the Increment of the bin. The dialog now supports setting the Number of Bins. The Frequency Counts dialog has been redesigned to allow users to select Step by Bin Size or Step by Number of Bins.

[edit] Others

JIRA Summary Description
ORG-1885 Support Transferring Column Formula in Transfer User Files dialog. Users can now transfer Set Column Values formula files from previous versions of Origin into the current version.
ORG-2196 Startup Tips dialog with useful tips. The Startup Tips dialog runs the first time Origin is run. It contains useful information on the new Sample OPJ, which provides an overview of Origin’s graphing and analysis functionality. The dialog also includes information on Origin’s Transfer User Files menu, which allows users to transfer customized files from previous versions, and the Check for Updates menu, which allows users to easily update their Origin software and help files.