ReleaseNotes:Bugs Fixed

From OriginLab Wiki

Jump to: navigation, search

Go back to Category:Origin 8 Release Notes


[edit] Index

  1. Analysis
  2. Graph Export
  3. Graphing
  4. Import
  5. Programming
  6. License Management
  7. Matrix
  8. Miscellaneous
  9. Worksheet
  10. Excel
  11. Com



[edit] Analysis

[edit] General

  • Failed to save Auto Preview option in xfunction dialogs with the <Last Used> Theme . ID = 10339. (SR1)
  • Bugs related to result output in operation dialogs. <auto> option added as default. ID = 10536. (SR1)
  • Auto complete hint not working for radio boxes in X-Functions. ID = 10735. (SR1)
  • Redundant results in the report sheets. ID = 10780. (SR1)
  • Crash when user opened an Analysis dialog with an axis on graph active. ID = 10549. (SR1)
  • With certain Regional/Language Settings such as French and Finnish, report options in various dialogs are ignored. (SR1)
  • Color names in ColorList control in X-Function dialogs is truncated in Japanese version. ID = 10620. (SR1)
  • Crash when copying long Notes from tables in report sheet. ID = 10919. (SR2)
  • Provide name specification for book and sheet in Operation-Based tools. ID = 10934. (SR2)
  • X-Functions specified with <input> for output variable fails to work when doing analysis on excel plot. ID = 11688. (SR2)
  • Fixed bad naming for output columns from operations. ID=11867 (SR5)
  • X's values are altered when there are missing values. ID=12356 (SR5)
  • Wrong column is used when selecting existing column from flyout menu if same Long Name and Short Name exist. ID=12642 (SR5)
  • Failure to establish autoupdate when output X shares the same as input X without keyword <input> ID = 12630. (SR5)
  • Fixed header assignments after statistics on rows -Beta_forum. ID = 12480. (SR5)
  • Reportsheet in OPJ created in SR0/1 lose some branches or shows incorrectly when opened in SR4. ID = 12560. (SR5)
  • Delete Recalculate does not clean up result sheet (for multiple tables case). ID = 12839. (SR5)
  • Recalculate did not work when input is range while output is worksheet. ID = 12501. (SR5)

[edit] Data Selection

top

  • Initial font size in Data Display window is too small when using Regional Data Selector tool, the initial font size in the Data Display window was too small. ID = 9629. (SR1)
  • Data markers remain in graph when editing range from either the Edit Range context menu or the Layer Contents dialog, ID = 10562. (SR1)
  • Failure to move data points with Data Reader even if Data Selector was used first. ID = 10658. (SR1)
  • Data cursors disappear for overlapped cursors. ID = 10611. (SR1)
  • After closing the Data Info window, it will not automatically pop up until user opens it again from the main menu. ID = 9856. (SR2)
  • Regional Data Selector selects hidden data. ID = 11850. (SR3)

[edit] Mathematics

top

  • Average Multiple Curves tool: Handle datasets whose X ranges do not overlap at all. (SR0)
  • Re( ) and Im( ): Parentheses surrounding Real and Imaginary components of the complex variable may cause compiling error. ID = 4386. (SR0)
  • Interpolate/Extrapolate tool: Errors occured when X values were large but their increments were small. ID = 11246. (SR2)
  • Interpolate/Extrapolate tool: Bug in spline interpolation that causes wrong result when the input dataset only had 4 data points. ID = 11044. (SR2)
  • Integrate tool: Failure to update output range when output is set to <input>, <new>. ID = 11444. (SR2)
  • Integrate tool: Failed to output Integration values to Results Log (SR4)
  • Integrate tool: Checkbox next to Output is missing. It controls creation of output columns. (SR4)

[edit] Fitting

top

[edit] General

  • When the Find Y from X table has more than one X column, user is now allowed to use set column values to share values for all X columns. ID = 10542. (SR1)
  • Wrong Analysis marker given to Fitted Curve. ID = 10796. (SR1)
  • Failure to save Number of Points of Fitted Curves in theme (SR2)
  • Crash when fitting from graph plotted from Excel book. ID = 11685. (SR2)
  • Error bars lost when fitting from graph. ID = 10970. (SR2)
  • Problems with checkbox Use Reduced Chi-Sqr ID = 11541. (SR2)
  • Problems after using Simulate Surface from the Function Organizer. E.g. Matrix window filled with 0. Failure to use Simulate Surface again. ID = 10875. (SR2)
  • Function type changes when duplicating a function in Fitting Function Organizer. ID = 11917.(SR3)
  • Theme Save menu fails to include theme settings' update . ID = 12056(SR3)
  • Analysis Marker size changes in different resolution. (SR4)
  • For G and J Origin, Failed to update user-defined function's file name. (SR4)
  • Replica branch's position in NLFit changed in SR2 and made SR1/SR0 project recalculate broken. ID = 12538. (SR5)
  • Failure to simulate curves evenly spaced on log scale -beta_forum. ID = 12564. (SR5)

[edit] Nonlinear Curve Fit

  • Significant Digits on Parameters tab lost when the dialog was brought up by Change Parameters. ID = 10551. (SR1)
  • Several bugs related to fitting reports of SR0 are fixed. The bugs include:
    • Failure to create residual plots when the fitted values are output to <Source> book and residual is output to <existing> book. ID = 10559. (SR1)
    • Residual vs. the Order of the Data Plot is a line+symbol plot, which should be a scatter plot. ID = 10559. (SR1)
    • Residual Lag Plot is gray and the y=0 line is missing. ID = 10559. (SR1)
    • Redundant empty sheets are generated for fitted curve value and residual plots even when user specifies to output neither fitted curve nor residual plots in the settings. ID = 10559. (SR1)
    • Wrong UCLs and LCLs for the parameters appear in some cases. ID = 10666. (SR1)
  • If the input data came from a hidden workbook, NLSF would fail to get the parameter names for the custom table that was pasted onto the input graph. ID = 10733. (SR1)
  • When you reopen the NLSF tool by Change Parameters, the Find Specific X/Y Tables branch is disabled. ID = 11605. (SR2)
  • Fixed several bugs related to NLFit themes:
    • Error in parameters Share and Fix status at theme changes.
    • Failed to save settings of "Enable Automatic Parameter Initialization" and "Enable Linear Constrains".
    • Theme values cannot be applied when the Enable Automatic Parameter Initialization check box is cleared and replica is enabled.
    • Theme loading result is not consistent with different loading procedure.
    • Parameter values are wrong when applying a replica theme to multiple datasets.
    • Parameter values for existing datasets can not be kept when adding or replacing datasets.
  • Parameter Share and Fix status is wrong in NLFit. ID = 10499. (SR2)
  • Fixed the error in Confidence and Prediction Bands of Fitted Curves in NLFit. ID = 10923. (SR2)
  • Fixed a bug that caused error in parameter initialization in old fitter (opened by nlsf.control()).ID = 10886. (SR2)
  • Fixed a bug that caused the decrease of height of fitted curve in report sheet, when recalculate is issued. ID = 10853. (SR2)
  • Now the X Data type of fitted curve info can be saved in themes. ID = 10442. (SR2)
  • When the NLSF dialog is opened with a graph plotted from Excel active, the input range will be picked up correctly. ID = 10587. (SR2)
  • When fitting with replica, parameter initialization now works for all supported function. ID = 11501. (SR2)
  • Switching from a function where number of replicas is larger than 0 to multiple independent/independent fitting function works fine now.ID = 12047(SR3)
  • NLSF theme with replica and shared setting can be applied correctly now. ID = 12023.(SR3)
  • For fitting with shared replica, fixed status will be remembered when the dialog is reopened by change parameter.ID = 12034(SR3)
  • Lower and Upper Bounds are now shown correctly in report sheet when fitting with replica function. ID = 12036(SR3)
  • Parameters and Bounds grid can be updated properly for multiple indep/dep-variables function. ID = 12048(SR3)
  • Lower and Upper bounds can be shown correctly in report sheet for multiple datasets fitting with sharing. ID = 12040(SR3)
  • Parameters and bounds tab will not turn blank when user switches from multiple datasets to replica. ID = 12055(SR3)
  • If the NLFit dialog is opened when a graph is active, the fitted curves will be added to the active layer of this graph. ID = 12035.(SR3)
  • Linear Constraints in NLSFit works fine now. ID = 10939. (SR3)
  • User-defined derived parameters can be shown in reportsheet table correctly. ID = 11593. (SR3)
  • NLFit will not dump unwanted empty input error when change input data on fitting from loose data . ID = 11775.(SR3)
  • Parameter initialization now works fine for multiple-independent functions. ID = 11816.(SR3)
  • Fly-out menu works in linear constrain theme. ID = 12067.(SR3)
  • Fixed bug concerning replica sharing failed after recalculate. ID = 12124. (SR4)
  • NLSF automatically add legend after fit even though there is no legend in souce graph. ID = 12539. (SR5)
  • Fixed X axis of fitted curve plot does not rescale in result sheet. ID = 11986. (SR5)

[edit] Compare Model/Compare Datasets

  • Fit Comparison tool: Fit Comparison Bugs. ID = 10589. (SR1)
  • Two bugs related to Fit Comparison tool are fixed: (SR1)
    • The P value will be missing in the F-Test table when F is large.
    • When detail AIC is large, there is a missing cell value in AIC table and the footnote is wrong in this case.
    • Comparing datasets using polynomial model, the degree of freedom is wrong
  • Fit Compare Model now can work even if RSS, SSE, DoF, N do not exist in NLSF result. ID = 10975. (SR2)

[edit] Polynomial Fit/Linear Fit/ Multiple Regression Fit

  • Polynomial Fit: Polynomial Fit with high order generated improper results. ID = 10741. (SR1)
  • When analysis dialogs like Fit Linear were brought up with the Regional Data Selector active, the first click on the interactive button would fail to work in SR0. Also the interactive button on the level of Input data of the Fit Linear tool did not worked well when the Regional selector was active. SR1 fixed these two bugs. ID = 10518. (SR1)
  • The default state of the Use Reduced Chi-Sqr checkbox in Linear Regression, Polynomial Regression, Multiple Regression now depends on whether weight is used: ID = 9498(SR0)
    • When weight is used, the check box is selected by default;
    • When weight is not used, the check box is disabled.
  • Polynomial Fit: Polynomial Fit generated improper results of Confidence and Prediction Bands for large magnitude data. ID = 13173.(SR5)

[edit] Fit Sigmoidal

  • Run time error caused by recalculate of Dose Resp(Analysis->Fitting->Fit Sigmoidal) fit is fixed.ID = 12025(SR3)


[edit] Nonlinear Surface Fit

  • Failure to paste linked table into source graph. ID = 11629. (SR2)
  • Failure to add Fitted Curves and Residual Curves to reportsheet when doing surface fit in graph. ID = 11685. (SR2)

[edit] Matrix Fit

  • Failure to clear Matrix Fit result sheet when the source data worksheet is cleared. ID = 11619. (SR2)

[edit] Data Manipulation

top

  • Fixed a bug that caused Curve Translate to be unstable. ID = 10509. (SR1)
  • Fixed bugs related to recalculate for Set Column Values. ID = 10754. (SR1)
  • Clicking the ">>" button in Set Column Values dialog will apply the current settings before going to next column. ID = 11034. (SR2)
  • Text pasted into the Set Column Values dialog will be treated as plain text. This improved the display of text. ID = 11031. (SR2)
  • Fixed a bug that caused broken links in extracted worksheet. ID = 11547. (SR2)
  • Fixed a bug where column calculations on large datasets will be much slower after you save your project. Reload project and the decrease in speed go away. ID=10898 (SR2)
  • Translate Vertical/Horizontal now can work on a selected range. ID=10913 (SR2)

[edit] Signal Processing

top

  • Fixed FFT rescales badly when peak is very sharp and frequency. ID = 12088 (SR3)
  • Smoothing: Add options to provide same results as Origin 75 in fft-filter smoothing. ID = 11828 (SR3)
  • Smoothing: Where smoothing on data with leading/trailing missing values and Output is set to <input>, <new>, leading missing values will be kept in output. ID = 12319 (SR4)
  • Smoothing: Output wrong when there is missing value in data. ID = 12319. (SR5)
  • FFT_Filter: X axis tick labels in preview are wrong for some data. ID = 12373. (SR5)
  • FFT Filter: Doing FFT Filter in a zoomed graph, the graph always rescales. (SR5)
  • FFT Filter: Failure to support not strictly even data. ID = 13429 (SR5)
  • FFT Filter: Improved speed when input is large data. ID=12246 (SR5)

[edit] Spectroscopy

top

[edit] Peak Analyzer

  • Crash when Integrating peaks with descending X values(e.g. XPS files). ID = 12049. (SR3)
  • Bad parameter initial values for non-gauss function when the baseline is not subtracted. ID = 12065. (SR3)
  • Failed to create fitting report when input Y column contained sampling interval and had no Long Name (SR4)
  • Fitted curve plot was missing in report sheet in PA and Nanosizer (SR4)
  • Failed to use multiple user-defined functions for multiple peaks. (SR4)
  • Make theme conversion for PA for backward-compatibility. Themes created from previous SR versions, such as SR3, SR4 are usable in SR5. ID = 12352 (SR4)
  • Failure to open PA dialog when Origin 8 Regular install Developer Kit. ID =13510 (coming SR6)

[edit] Fit Multiple Peaks

  • Fit Multi-Peaks: Not working with descending X. ID = 11287, 11302. (SR2)
  • Fit Multi-Peaks Multipeak fit should not care about monotonicity. ID = 11302. (SR5)

[edit] Statistics

top

  • Fixed a bug that caused incorrect results for rowstats with input ranges from multiple sheets. ID = 10777. (SR1)
  • Fixed a bug that caused Origin to be frozen when the "x" button is clicked to close the ... data selection dialog in Two-way (RM) ANOVA. ID = 10436. (SR1)
  • Fixed a mouse click problem that happened when user tried to expand the Means Conparisons node of the ANOVA report sheet. ID = 10738. (SR1)
  • Fixed the error of Means (Comparisons) plot data in ANOVA tools. ID = 11610. (SR2)
  • Plots in ANOVA results will be correct after recalculation. ID = 10992. (SR2)
  • Fixed a bug that caused recalculation of Stats on Rows to fail when rows were selected by clicking the row header. ID = 11624. (SR2)
  • The Results Log Output checkbox now works for One Sample t-test. ID = 11655. (SR2)
  • Changed text "Levene||" under "Tests for Equal Variance" tree node to "Levene ||". ID = 12295 (SR4)
  • Fixed Tick labels of Y axis in Means comparison plots problem. ID = 10736 (SR5)
  • Frequency Counts supports user supplied bin vector. ID = 12735 (SR5)

[edit] Graph Export

top

  • Image size incorrect when exporting a non-active graph. ID = 6373. (SR0)
  • Label shifts in exported graphs. ID = 10803. (SR1)
  • Mouse flashing and dialog redrawing in 'Export Graphs dialog. Id = 10286. (SR1)
  • Crash when exporting a large worksheet as an image. In addition, user can control the limit for number of rows and columns to export via system variables now. ID = 11443. (SR2)
  • The Export Graph dialog failed to handle themes with Path set to <Project Folder> properly. ID = 11005. (SR2)
  • PDF export of graphs fails with Outline mode . ID = 11500. (SR2)
  • Export of Layout fails with Tight page setting. ID = 11514. (SR2)
  • Table on Graph failed to be exported.ID=12101 (SR4)
  • Focus of cell shows in worksheet's exported pdf file. ID = 12656. (SR5)
  • Origin crash when export file path is very long. ID = 13571. (coming SR6)

[edit] Graphing

top

[edit] 2D Graphs

  • All layers of the Multi-Curve plot types, such as Vertical 2 Panel, now have a legend. ID = 9752(SR0)
  • Plot a graph by Plot: Specialized: Zoom, and move the zoom window. Now it works fine. ID = 9804. (SR0)
  • The automatic rescale of axes will now take into account error bars. ID = 10047(SR0)

  • Mixed text and numeric data in an X column of type Text & Numeric will no longer cause a Column plot of dependent Y columns to display as thin line. ID = 10190(SR0)
  • Fast line drawing in log scales. In SR0, this bug caused error display of negative values in line plot when log scales were used. ID = 10831. (SR1)
  • 2D Waterfall plots. These bugs include:
    • Waterfall in Origin 8 doesn't support fill color under each waterfall plot.
    • Waterfall graphs created in 7.5 (which has filling colors under each curve) will be messed up when they are opened in 8.0.
    • One has to rescale the graph so as to update the parameter index changes in waterfall.
    • Cannot clip the data to a limited scale.
    ID = 8846. (SR1)
  • Crash when a graph had two data plots from the same dataset and user removed one of them. ID = 10697. (SR1)
  • In scatter plots, data labels fail to show those from Text&Numeric column. ID = 11178. (SR2)
  • Offset Grouped Data works on polar graph. So user can create windrose plots. ID = 10974. (SR2)
  • Adding box chart to grouped plots will not cause crash any more. ID = 10848. (SR2)
  • Plotting a line plot from an X column that is set as "text" and a Y column that is set as "numeric" will not caused display error. ID = 10965. (SR2)
  • no data will plot when both XY are filled with pure text data. (SR2)
  • Auto Legend does not always work for multi-layer graph. ID = 11981. (SR3)
  • Waterfall plot fails if Parametrers Row has text data. ID = 12174 (SR4)
  • Specify user-defined parameters as Parameter Index for waterfall plot (SR4)
  • Wrong tick label type when certain plots made-beta_forum. ID = 12461. (SR5)
  • Cannot plot multiple curves from Excel where XY order is reversed. ID = 6733. (SR5)
  • Labels from Excel do not update when project is opened. ID = 10125. (SR5)
  • Show all Data Plot does not show data points if there is error bar. ID = 12102. (SR5)
  • Drag & drop to add a scatter plot, with Yerr data, Y data is missing ID = 12739 (SR5)
  • Tick label type problems making data disappear. ID = #12474 (SR5)
  • Missing values are treated as 0 in stack lines by Y offsets if column format is numeric.ID = 13430 (SR5)


[edit] Statistics Graphs

  • Y axis increment in Mean Comparison plots for ANOVA. ID = 10736. (SR1)
  • Histogram data binning failure after customization. ID = 10769. (SR1)
  • Crash during customization of histogram plot. ID = 11459. (SR2)
  • Active sheet turns to last sheet after running Stacked Histogram. ID = 11758. (SR3)
  • Box Chart fails when Refreshed (Rescaled or Print Previewed). ID = 12428. (SR5)

[edit] 3D Graphs

  • Rotating a 3D color map graph window will not change color, even graph axes are reversed (From greater than To). ID = 7898. (SR0)
  • 3D color map surface plot will not shows backplane pieces with Rough Data Surface. ID = 8375. (SR0)

[edit] Contour Graphs

  • Data boundary to disappear in XYZ contour plots. ID = 10573. (SR1)
  • XYZ contour plot gets screwed up if same Y column used to make column plot. ID = 10818. (SR1)
  • Contour plot created from some special data make origin crash. ID = 10836. (SR2)
  • XYZ/Polar contour failed to correctly recognize column with sampling interval. ID = 11755. (SR3)
  • Need refresh polar contour drawn from excel in old OPJ. ID = 12424. (SR5)
  • Wrong Z Value in contour profiles plot. ID = 12620. (SR5)

[edit] Function Graphs

  • In Function Graph, the function name showed in the Plot Details dialog will no longer be gibberish. ID = 10534(SR0)
  • X column can be shown correctly from a worksheet from a Function Graph. ID = 11283. (SR2)

[edit] Graph Customization

  • For rectangle or circle objects, they are filled with the black color instead of none when we choose "black" from the Fill Color drop-down list of the Object Properties dialog. (SR0)
  • Copying and Pasting format will no longer make Origin crash. ID = 9293(SR0)
  • Copy/Paste graphic object must reset UID. ID=11763. (SR3)
  • Special data point in plot can be re-reintegrated/revert to the plot by selecting context menu Delete. ID=11968. (SR3)
  • Deleting of a graph layer can undo. ID=12121. (SR4)
  • Cursor that added into point will make Origin infinite loop (SR4)
  • Use long text as axis tick label make Origin crash -Beta_forum. ID = 12212. (SR4)
  • Setting cell value in column formatted as Text & NumerFic lose leading zeros (SR5)
  • Origin was locked when pops up Reminder Message about Speed Mode. ID = 11919. (SR5)
  • OEM Customer Issues in trying to move to Origin 8. ID = 12381. (SR5)
  • Preview in Layer Management should set the same page orientation as source graph. ID = 12464. (SR5)
  • Number of Major Ticks is incorrect when the # of Major Ticks is specified. ID = 7535. (SR5)
  • Plot failed to correctly rescale when editting Time type of tick labels. ID = 12211. (SR5)
  • Support more format for custom legend in Origin.ini. ID = 12269. (SR5)
  • Data markers position changes when move the range in zoomed mode. ID = 12586. (SR5)
  • Not easy to select a text label. ID = 12936. (SR5)
  • Solid interior showing is correct now which is set by advanced legend.ID = 13235.(SR5)
  • Add Bottom-X Left-Y Layer failed to work in German Origin8sr5 ID = 13564 (coming SR6)
  • German Umlauts on VISTA turned into Arabic ID = 13450 (coming SR6)

[edit] Plot Setup

  • Sorting columns by Position in the Plot Setup dialog, will now sort correctly (numeric sort so you get 1, 2, 3,... and not 1, 10, 11,...). ID = 9632(SR0)
  • The Plot Setup dialog is capable of displaying and plotting multiple sheets from an Excel workbook. ID = 6202(SR0)
  • Select any dataset in Plot List panel in Plot Setup dialog will not affect the Available Data drop-down list. ID = 7718. (SR0)
  • Double-click on the Graph Layer icon to bring up the Plot Setup dialog, add data plots in sequence, now plot list will follow order in which plots are added. ID = 8516. (SR0)
  • Plot Setup: focus wrong or lost after an Ungroup. ID = 8536(SR0)
  • The feature PLOT by row number will now work fine, and the Curve will no longer be disappears. ID = 9625(SR0)
  • Plot Setup changing Yerr to Y+ Y- not refresh the plot shortly. ID = 11973. (SR3)
  • Apply button status should be clearly set in Plot Setup. ID = 11984. (SR3)
  • Add Plot to Layer menu failed to select the correct plot type in Plot Setup dialog (SR4)
  • New Plot Setup Column Selection Improvements (SR4)
  • No matched worksheet is highlighted in Available Data panel when select plots in Plot List panel in PLot Setup (SR4)
  • Designation selection can not be kept when switch diff modes in Plot Setup -Beta_forum. ID = 12369. (SR5)
  • Plot Setup forgets the X Error Bar checkboxes although is was used last time ID = 12437 (SR5)
  • Plot type such as Stack Area can't be kept when using replace button in Plot Setup. ID = 12738 (SR5)

[edit] Plot Detail

  • If you turn on the Fill Area Under Curve setting in Plot Details for your line plot and then save your graph as a template, this setting will now be saved. ID = 2811. (SR0)
  • Removing one data plot from a graph that have two data plots from the same dataset in Plot Details dialog will remove both plots in SR1. ID = 10713. (SR1)
  • Operation in the Plot Details dialog will not switch active layer any more. ID = 11690. (SR2)
  • Crash when press "ESC" in plot details dialog when "BinSize" edit control actived. ID = 11864. (SR3)
  • Graph can not rescale when changing its Offset in Stack tab of Plot Details. ID = 11700. (SR3)
  • Crash happened when Alt+W is used in the Plot Details dialog. ID = 11733.(SR3)
  • Improvements needed for Log Scale in Setting Levels for a Contour plot. ID = 12837. (SR5)
  • Floating Column plot color map bug. ID = 7480. (SR5)
  • Plot Details Group Tab Increment Column need indication to click. ID = 13226. (SR5)

[edit] OLE

  • OLE problems that occurred in Windows Vista:
    • Failed to add texts into graph in PowerPoint.
    • A waning message appeared when a graph was paste to Word.
    • Pasting a graph with table as Origin Object into Word caused crash of a separate Origin instance.
    • Opening the Plot Detail dialog in the edit mode of embedded Origin graph led to crash.
    ID = 11372. (SR2)
  • OLE: Embedded graph in Microsoft Word will always keep the same as it is opened in Origin. ID = 10909. (SR2)

[edit] Theme Organizer

  • The Undo and Apply buttons did not work fine in the Theme Organizer. ID = 10269. (SR1)
  • Incremental theme can be saved and shown in Sr3 . ID = 11912. (SR3)

[edit] Graph Template

  • Data label properties failed to be saved with graph templates. ID = 11457. (SR2)
  • Plot button in Template Library works for contour and polar contour plots. ID = 11553. (SR2)
  • Custom plot templates could not appear by name in Recent Plot menu, but Template Library. ID = 12749. (SR5)

[edit] Import

top

  • Status of Results Log Output checkbox can be saved in dialog themes of import features. ID = 11189. (SR2)
  • Open -w filename have diff behaviour of rename for 8.0 and 7.5. ID = 13376. (SR5)

[edit] Import Wizard

  • The Import Wizard in SR0 could not read information regarding column name and column label in filter files created with Origin 7.5. SR1 has improved the support for Origin 7.5 import filters. Thus, The column names from Line in an Origin 7.5 filter is read and converted to Short Names, and The column label lines from and to are used for Column Comments. Additionally, the value for Number of header lines is used for main header lines and sub header lines now. ID = 10434. (SR1)
  • Fixed a bug in German version that caused importing fail when the Import Wizard used <None> for filter. ID = 10723. (SR1)
  • If the data in a worksheet was imported with by the Import Wizard and you chose File: Import: Reimport By Changing Options from the menu in SR0, the data in the worksheet would be erased. SR1 fixed this bug. In SR1, when you use Reimporting by Changing Options with data imported with the Import Wizard, the dialog of the impASC X-Function opens and you are allowed to change the import options in the dialog. ID = 10761. (SR1)
  • Setting data format to date for double data and setting Designation for date columns in the Import Wizard now works properly. ID = 11544. (SR2)
  • Fixed a bug that ComponentOne dialog opens in G Origin G GUI Import Wizard when click Next to Data Columns page. The dialog opens at first use of each Origin session. (SR2)
  • Fixed a bug Text only ASCII file does not import using import wizard. Allow Import All Text Data option is checked by defaut now. ID = 11945. (SR3)
  • Can't type numbers to count column in Data Patten page of Import Wizard. ID = 12260. (SR5)
  • Import Wizard's Header Variables need support for multiple space delimiters. ID = 13672. (coming SR6)

[edit] Import Excel

  • Excel importing can handle multi-line comments in SR1. Header line settings can be applied to all sheets. ID = 10622. (SR1)
  • When an Excel workbook with multiple sheets was imported in SR0, the column designation was not shown for sheets other than the first sheet. SR1 fixed this bug. ID = 10816. (SR1)
  • Fixed a bug that caused some Japanese characters to be lost when the Import Excel feature was used. ID = 10571. (SR1)
  • Redundant empty columns at the end of Excel file would not be imported. ID = 10811. (SR1)
  • Excel import Supports allowing which sheet(s) to import. ID = 10625. (SR2)
  • Excel cells with space should be considered as empty when importing Excel (SR4)
  • Fixed redundat box when loading theme in import Excel dialog. ID = 12435. (SR5)

[edit] Import Third Party Files

  • Incorrect scaler in pClamp plot. ID = 10671. (SR1)
  • ETAS INCA MDF feature broken in sr1 German Version. ID = 10911. (SR2)
  • Failed to show info icon on header in SPC import if there is no sampling interval. ID = 12811. (SR5)
  • Failed to get negative start time value in pClamp Import. ID = 12413. (SR5)

[edit] Import ASCII

  • Fixed an Import ASCII error in German OS. ID = 11349. (SR2)
  • Fixed the bug about Append Rows option of impasc XF destroys Date information. ID = 12315. (SR5)
  • One column ascii data with comma numeric separator failed to be imported -Beta_forum . ID = 13008. (SR5)
  • Import ASCII should clean embeded note. ID = 13605. (coming SR6)

[edit] Programming

[edit] LabTalk

top

  • system.fileext.addtype() method fails. This is not used in Origin80 any more. ID 6170(SR0)
  • run the scripts into OEvents.ogs to compile OC files at Origin startup error. ID 9229(SR0)
  • layer.z.inc returns z increment now. ID = 8123. (SR0)
  • Create a graph window with at least two layers. Single-click on a layer in a graph window to select it such that the highlighted boundary with control handles displays. Run layer -d in the script window. Origin will not crashes. ID = 8291. (SR0)
  • Fixed a bug related to LabTalk access to Excel. Note that "page -us" must be used before "page.active=" is executed when an Excel book is active. ID = 10739. (SR1)
  • In SR0, the int(x) function, which returns the truncated integer of x, will give a Command Error. In SR1, it can now be executed. ID = 10678. (SR1)
  • Fixed a bug that caused "External call execution error" or crash when layer -r was executed with a worksheet active. ID = 10712. (SR1)
  • When the basecolor of a graph page is a custom color, page.basecolor= can return the value calculated from the RGB components of this custom color by the color(r,g,b) function. ID = 10696. (SR1)
  • When calling an X-Function with multi-column range, user can now use expressing in row index of the range. ID = 11013. (SR2)
  • Improved the checking for dot separation. Now user can use data filling like col(d)={1:.5:2};, which used to generate error. ID = 11098. (SR2)
  • Wks.cNamen$ now works fine. ID = 11179. (SR2)
  • Scripts like dataset1=dataset2[dataset3] now work properly. ID = 11146 . (SR2)
  • _INTEG_AREA will be generated correctly after the integ command is used. ID = 10988 . (SR2)
  • Fixed several bugs related to GetToken for LabTalk string variables. ID = 10927 . (SR2)
  • Fixed a bug that caused Origin to crash at startup if there is a toolbar button with LabTalk expression involving a page layer. ID = 11083. (SR2)
  • Loose datasets can be plotted with the plotxy X-Function. ID = 11198. (SR2)
  • Fixed several range problems related to the copy command. Now copy -a and copy -u work properly. ID = 10938. (SR2)
  • The doc -a command now works properly when filename is enclosed by quotation marks. ID = 11313. (SR2)
  • Fixed a bug that caused incorrect path shown in most recent used file list after the Save command is used. ID = 11138. (SR2)
  • "%C" now works as "<active>" in setting value to a X-Function variable. ID = 11577. (SR2)
  • Fixed a bug that caused the script label -r line not to work when it is set to run after an object is moved. ID = 11562. (SR2)
  • Fixed a bug in SR1 that caused the mark -d command fail to work for two segments of plot in same section. ID = 11669. (SR2)
  • The Average command now works. ID = 11652. (SR2)
  • Fixed a bug that caused getsize() not to work with dataset. ID = 10862. (SR2)
  • Origin quits if ogs name conflicts with LT commands namewhen run an ogs file. ID = 11937. (SR3)
  • Fixed work -b winName and win -n plot [winName] commands.ID = 11827. (SR3)
  • Fixed derivative -p option commands. ID = 11970. (SR3)
  • If define tree before use Nlbegin, junk will not be dump to result log now. ID = 12024(SR3)
  • Asian characters used to make commands fail to work in Classic Script Window. This bug was fixed in SR3. ID = 11613 (SR3)
  • LT: derivative failed when there exists an X column with same values as Y column (SR4)
  • limit command broken (SR4)
  • LT. destination col should auto create for all cases - beta_forum. ID = 12529. (SR5)
  • Copy -b not creating destination if not existed- beta_forum. ID-12514 (SR5)
  • XYRange should resolve LT col range variables. ID = 12457. (SR5)
  • Need show error when pass wrong value to XF. ID = 12712. (SR5)
  • doc -e s {} will updating %C properly for range variable. ID = 12872.(SR5)
  • Fixed bug Legend with lots of text crashes Origin. ID = 11472. (SR5)
  • Worksheet cell edit mode arrow keys no longer works-beta_forum. ID = 13089. (SR5)
  • New graph name should not enum from plotxy-beta_forum. ID = 13238. (SR5)
  • Plotxy p:=206 failed, box chart plotting from LT - beta_forum. ID = 13244. (SR5)
  • LT: exist() failed to correctly check existing sheet/dataset - beta_forum ID = 12913. (SR5)
  • New column that is created by colcopy xfunction will not be set name to Destination Column. ID = 13340 (SR5)
  • External call execution error caused by wks.iscolsel( )-Beta_Forum ID = 10857 (SR5)
  • %C return empty when no dataset is active.ID = 12911 (SR5)
  • XF LT new book from output range should allow long name ID = 13504 (coming SR6)
  • LT string comparison should not care if quoted when wildcard is used ID = 13502 (coming SR6)

[edit] Origin C

top

  • int TreeEditor::GetSelectedRows(vector<uint> *parrRows = NULL, BOOL bExcludeBranchNodes = FALSE); when the ptr is NULL, since we always create a memory ptr if NULL on call. Right now the method (in the OCTreeControl class) fails when the ptr is NULL. ID=4264. (SR0)
  • Project.ActiveCurve incorrectly returns valid curve when X dataset is selected. ID 4311. (SR0)
  • string::Replace fail to work correctly. ID 4586 (SR0)
  • SetReportTree() after running, Origin will crash. ID 6341 (SR0)
  • memset and memcpy method fail to work when set buffer to a struct including string pointer. Testing code is not right. ID 6484 (SR0)
  • Cause crash when use float data as the first two arguments in GetMinMax method.Now compile error(right). ID 6512 (SR0)
  • Need to support overload between Dataset and vector arg Fixed. ID 6899 (SR0)
  • Using == to compare vector<string> with NULL will cause crash. ID 7084 (SR0)
  • Function TreeNode:GetAttribute(LPCSTR lpcszAttrName, double &dVal) will crash if the attribute is an string one. ID 7461 (SR0)
  • Function String::Match get incorrect return when the string length is larger than 260. ID 7497 (SR0)
  • Function AddNumericNode fail to work correctly when dVal = NANUM. ID 7529 (SR0)
  • Origin will not crash when creating subfolders from Origin C. ID = 7746. (SR0)
  • If workbook name is a reserved OC function, data can be plotted plot now. ID = 7926. (SR0)
  • Missing ';' (semicolon) will not causes crash during build. (For example: var++ //Missing ;. ID = 8969. (SR0)
  • When a layer is rescaled with OC code, the layers linked to it will be also rescaled automatically. ID = 7364. (SR0)
  • Fix a bug that scales of layer can not be selected or clicked in some cases. ID = 9326 (SR0)
  • DataPlot::SetColor() did not work for scatter plot in SR0. SR1 fixed this bug. ID = 10781. (SR1)
  • Undo is now supproted if worksheet theme is applied or column shortname is set by Origin C. ID = 10220. (SR1)
  • Fixed a bug tha caused compiling error when there were several files with the same name but stored in different subfolders. ID = 10677. (SR1)
  • Converting DWORD to DLGSIZEINFO pointer would lead to Origin crash in SR0. SR1 fixed this bug. ID = 10750. (SR1)
  • Matrix access by bookname(sheetname) now works properly. ID = 11528. (SR2)
  • Passing Col(1) as argument to OC function works in 80 now.ID=11976.(SR3)
  • Compile failure with nag function that requires NAG_FREE is fixed. (SR4)
  • Before SR3/4, there was a bug with the AddTextNode() method. When its string argument does not begin with a char, it is interpreted and set as a double value automatically when applying SetSection() method. This bug was fixed in SR3.(SR3)
  • Fixed bug about Setting cell value in column formatted as Text & Numeric lose leading zeros. ID = 12404. (SR5)

[edit] XFunction

  • Fixed XF command line arg failed if "has : inside" -Beta_forum. ID = 12340. (SR5)
  • Fixed a bug that caused redundant XF dump file. ID = 10547. (SR1)

[edit] License Management

top

  • Switching between wired and wireless network access no longer causes the License Information dialog box to display with node locked Origin. (SR0)
  • Node locked license files based on Computer ID work fine on Vista. (SR0)
  • Dongle drivers with dongle managed Origin work fine on Vista. They also work fine on 64 bit Windows and when Windows goes into Standby mode. (SR0)
  • Modify failed to install dongle drivers ID = 10540 (SR2)


[edit] Matrix

top

  • matrixbase::ApplyFilter() doesnot work properly when filter has negative parameter. ID = 4460(SR0)
  • Matrix View Mode not changed by OC setting bSetViewData flag in SetInternalData. ID = 7427(SR0)
  • MatrixLayer::Reset work incorrectly when Matrix is 2*2 and the parameter is true. ID = 7565(SR0)
  • MatrixLayer::SetNumCols and SetCellWidth work correctly when the value of the parameter is less than 1. ID = 7716(SR0)
  • Copy a block of matrix cells, and then paste on the source matrix, will not causes crash. ID = 9505. (SR0)
  • Set Matrix value in Origin 75, save the OPJ, and open it in 80. Select Matrix: Set Values, the cell value function will be showed on the edit box. ID = 9589. (SR0)
  • The formula of a matrix cell in a Origin 75 OPJ will no longer be invisible when opened in Origin 8. ID= 9589. (SR0)
  • When auto recalculate is on for a matrix, all cells are not modifiable. ID = 10670. (SR1)
  • Fixed errors XY mapping and plotting as an image plot for matrix object that has only 1 column. ID = 10945. (SR2)
  • Description in w2m x-function show correctly when change data format.ID=11949 (SR3)
  • Image crop and copy context menu did not work in JOS. ID = 11995. (SR3)
  • Fixed Image info like bits and color in matrix window were changed after saving project -Beta_forum . ID = 12478. (SR5)

[edit] XYZ Gridding

  • XYZ Gridding tool can be opened in SR1 when Origin is launched for the first time. (SR1)
  • Worksheet Gridding now works even when X and/or Y data has missing values. ID = 10984. (SR2)
  • For large data, some dropdown list in XYZ Gridding dialog are too narrow. (SR4)
  • XYZ gridding of regular data with different number of X and Y broken in sr4 ID=12341 (SR5)
  • XYZ gridding theme not working correctly ID=13035 (SR5)

[edit] Image Processing

top

  • Fixed a bug that when image Extract to XYZ, "Keep Preview" Check box is misleading and Hide/Show XF panel could not trigger close event. Besides,Close (delete) window page could now trigger close event for 3D graph in XFs: img2xyz and imgSubtractInterpBG. ID = 12100. (SR3)
  • Do Analysis: Histogram after image Profile make Origin Crash. (SR3)
  • Add and improve zoom ability in preview panel for image. ID = 11804 (SR4)
  • Crash when openning imgReplaceBg DB with converted gray image activated. ID = 12387 (SR5)
  • Converting image matrix to data should set coordinates to pixel size ID = 13032 (SR5)

[edit] Miscellaneous

top

  • Axes missing, File Open fails, script fails, OPK fails to unpack - Bug related to HP Laserjet PCL driver have fixed. ID = 7442. (SR0)
  • Fixed a bug that caused toolbar settings to be lost when the bitmaps, script files and ini files were saved in subfolder under user files folder. ID = 9103. (SR1)
  • Bug related to Camtasia has been fixed. ID = 10814. (SR1)
  • Mathematica Link works in SR1. (SR1)
  • Now ALT+3 can work properly in toggling the Command Window on and off. ID = 10067. (SR2)
  • The Save Changes to Project message will not pop up when user clicks the New Project button, if the current project is never modified. ID = 11069. (SR2)
  • Setting numeric numbers to a fixed format (such as fixed decimal, fixed significant digits) now affects "0" as well. ID = 11373. (SR2)
  • Most Recently Used (MRU) items remove themselves after load failure. ID = 11870. (SR3)
  • The unwanted "Window: Please Wait" shortcut menu item that remains on workspace gray area has been removed. ID = 11882.(SR3)
  • "Singe Peak Fit.xls" and "Analysis Template.xls" in Samples\Automation Server\Excel folder do not work (SR5)
  • Page orientation can be remebered in workbook.ID = 13294 (SR5)

[edit] File Saving/Loading

  • Some OPJ file save in 75, 80 crashes in 6.x when accessing Window menu. This is because window label is getting too long. Run this script to fix it: doc -e W {page.title=2}; ID = 7982. (SR0)
  • Fixed a bug that caused Origin C recompiling when user double-click or use command line to open an opj with an Origin instance already running. ID = 10743. (SR1)
  • Recalculate would not be polluted after the opj was saved in Origin 7.5. ID = 10753. (SR1)
  • When user chooses to save a built-in template, the template is saved to the User Files Folder. ID = 11175. (SR2)
  • Saving an opj file with excel file (which has "()" in sheet name) now works fine. (SR2)
  • Fixed a bug that messed up the workbook organizer in project after it was saved in Origin 7.5. ID = 10763. (SR1)
  • Fixed a bug that caused Origin to hang when a second instance of Origin was started by opening a project file with Origin C files set to Build on Startup. ID = 10935. (SR2)
  • The current project will be kept If user click the New Project button and then click Cancel in the message box that asks whether to keep the current project. ID = 11720.(SR3)
  • Invalid window name (saved in previous version) should be corrected when opening in Origin8, ID=10718 (SR3)
  • Fixed Open xlsx failure in Origin (SR3)
  • File export/saving sucess message will force script window open (SR5)
  • Open OGW saving will alter OPJ save path ID = 13517 (coming SR6)

[edit] Transfer User Files from Previous Version

  • Fixed bugs that caused error in transferring user files for Version 7.5 client mode or student version. ID = 11227. (SR2)
  • Transfer User File failed to find 7.5 client ID=11227(SR2)

[edit] Group Folder

  • Failure to disconnect from group in Set Group Folder location dialog. (SR4)
  • Group clients uses Origin 8C registry instead of Origin 8. (SR4)

[edit] Installation

  • Fixed a bug that caused all X-Functions to be removed if user cancelled the repairing. ID = 10602. (SR1)

[edit] Layout

  • Fixed a bug that objects in the layout can not change to picture holder when Apply to window. ID = 11818. (SR3)
  • Worksheet picture in layout page can now be snapped to grid. ID = 11823.(SR3)

[edit] Project Explorer

  • Fixed a bug that caused Project Explorer not to be opened when user double-clicked on an OPJ file to launch Origin. ID = 9985. (SR2)
  • Failure to rename workbook starting with number in Project Explorer. ID = 11802. (SR3)

[edit] Documentation

  • In German version, the Help: Programming menu command in Code Builder can open the help file correctly. ID = 11141. (SR2)
  • User can now access Origin.chm with help command in LabTalk. ID = 11309. (SR2)
  • F1 mapping to commands and variables in Code Builder not working. ID = 11932. (SR3)
  • Text in XF Help dialog cannot be selected/copied (SR5)

[edit] Localization

  • Fixed a bug that caused wrong menu language when either English or German mode was used in Japanese OS. ID = 10805. (SR1)
  • Fixed a bug that caused gibberish in X-Function Builder and the Extract Worksheet Data dialog for Japanese version installed on English operating system. ID = 10657. (SR1)
  • In SR0, German thousand separators in worksheets created from graphs generated by Origin 7.5 were not properly handled. SR1 fixed this problem. ID = 10744. (SR1)
  • Fixed a bug in German version that caused incorrect numeric separators when results were output to Script Window, Results log and Notes window. ID = 10729. (SR1)
  • Project file named with special characters such as German umlauts can be opened correctly now. ID = 11055. (SR2)
  • Most Recent Used menu (MRU) shows special characters such as Umlauts -Beta_forum. ID = 12390. (SR5)
  • Fixed the bug about default font in Option causes gibberish in GUI interface. ID = 11960. (SR5)
  • Fixed several problems related to the Change Language feature. (SR2)

[edit] Demo

  • Evaluation watermark now says Demo. (SR1)

[edit] Worksheet

top

  • If you paste a long string that contains more than 73 characters in a label column, the string will no longer be truncated. ID = 6175. (SR0)
  • Numeric display in the worksheet column: Double-click on the column heading to open the Column Properties dialog. To set fixed number of decimal places, select Decimal: 1000 from the Display drop-down list, choose Set Decimal Places = from the Digits drop-down list, and then enter a proper number in the Decimal Number edit box. For example, if you set 3 as the Decimal Number, the value 0.000005 will display as 0.000 where as in the past it would have been displayed as 5.000 E-6. ID = 7862. (SR0)
  • Fixed a bug that caused crash when user deleted a hidden workbook with linked cells that had been cleared. ID = 10614. (SR1)
  • Using CTRL+V to paste a link to a graph into a worksheet cell now works properly. ID = 11057. (SR2)
  • Fixed a few bugs with the wrowheight X-Function. ID = 11148. (SR2)
  • Now the following X-functions can handle multi-sheet ranges:
    • colint
    • wcolwidth
    • wrowheight
    • colshowx
    • wreplace
    • wcellcolor
    • wcellsel
    • wcellmask
    • colmove
    ID = 10946. (SR2)
  • Fixed several problems related to auto filling or copying/pasting of embedded/linked objects. ID = 11016. (SR2)
  • Improved the move and rename commands in the worksheet tab context menu. ID = 11161. (SR2)
  • Multisheet selection now supports deletion. ID = 10891. (SR2)
  • Fixed a bug with wrong focus after a sheet is renamed in organizer. ID = 10902. (SR2)
  • The colint Xf works when the whole sheet is selected. ID = 11173. (SR2)
  • The New Book button now resets sheet name. ID = 11262. (SR2)
  • Fixed a bug that caused lost of column settings when the Decimal Digits property is set in the Format tab of the Worksheet Properties dialog. ID = 11377. (SR2)
  • Copying and pasting multiple columns, which include both Text&Numeric and Numeric only columns, will not cause cell missing any more. ID = 11363. (SR2)
  • Fixed a bug that caused flashing and endless updating when a workbook with inserted variable as Link is duplicated. ID = 10791. (SR2)
  • Fixed a bug that caused crash at hiding graph layer in sparkline graphs. ID = 11485. (SR2)
  • User can now go to the end of extremely large worksheet. ID = 11643. (SR2)
  • Now, user can use CTRL+V to paste text into the name filed of a worksheet. ID = 11473. (SR2)
  • Setting fonts to a selected cell with the Style toolbar now works the same as settings fonts for in-place editing. ID = 10555. (SR2)
  • Fixed a bug that caused failed in converting yyyy'.'MM','dd date format. ID = 10819. (SR2)
  • Reserved labtalk variables are not allowed for alias in Extract Worksheet Data. ID = 11918. (SR3)
  • Fixed a bug that change column's short name to number only. ID = 11916. (SR3)
  • Ctrl+X for cut-and-paste can work in column headers(longname, comments). ID =12014. (SR3)
  • Hugh slowness in wks redraw introduced in SR3. (SR4)
  • Fixed the bug about Copy error in cell edit mode-Beta_Forum. ID = 12364. (SR5)
  • Embedded graph are kept in memory until restarting Origin. ID = 12920. (SR5)
  • Can't export a sheet who was imported a file with long name as image. ID = 12867. (SR5)
  • Merged long name should not affect column selection - Beta_forum. ID = 12648. (SR5)
  • Page Size indicators (page break preview lines) in worksheet fail to refresh. ID = 12520. (SR5)
  • Crash on undoing multiple columns modification. ID = 13286. (SR5)
  • Alt shortcut keys did not work when focus is inside Workbook Organizer - Beta_forum. ID = 13329. (SR5)
  • Trouble renaming Column E. ID = 13583 (SR6)

[edit] Excel

top

  • Labels from Excel do not update when project is opened. ID = 10125. (SR5)

[edit] Com

top

  1. Fixed a few bugs related to COM:
    1. Cannot send a string through SetData() to column which is set to "Text" or "Text&Numeric" DataFormat
    2. Cannot show complex data in correct way.
    3. Cannot send Boolean data through the SetData() method.
    4. Long, ulong and decimal don't work in C#; long and currency don't work in vb.NET.
    5. DataFormat for MatrixObject doesn't work fine.
    6. SetSize() for Worksheet and MatrixSheet does not work like corresponding OC methods
    ID = 11319. (SR2)
  2. Fixed a bug that GetData will get some empty columns from origin when getting less than 32 data from a sheet with default 32 rows. ID = 11808 (SR3)
  3. Fixed a bug that Origin COM could not call XF on startup ID = 12053 (SR3)
  4. Fixed a bug that SetData from COM to Column not doing proper update ID = 12083 (SR3)
  5. Automation Server\Excel\ examples we ship with SR2 DO NOT work with Vista+Excel2003 (SR3)
  6. Fixed a bug that Origin cannot be closed because it is connected to other applications ID = 12257 (SR4)
  7. Matrix related support for LabVIEW is added, new sub-VI about matrix manipulation are put into a new palette called OriginMatrix_LV7.llb, Matrix Access.vi is created too ID=12256 (SR4)
  8. Fixed a bug that two samples: Single Peak Fit.xls and Analysis Template.xls from \Samples\Automation Server\Excel can not work ID=12346 (SR5)
  9. Fixed a bug that COM FindMatrixSheet exception when passed in bad name ID=12363 (SR5)
  10. Fixed a bug that Histogram plot beyond X, Y axis range can not refresh immediately when using LabVIEW example ID=12555 (SR5)
  11. Fixed a bug that COM Worksheet SetData append broken when using XY. Now plot the data and set axis to allow bigger X range and then Append data from COM and should see graph update nicely without flashing. ID=12860 (SR5)


back to Release Notes