Origin 8.5.1 Graphing

From OriginLab Wiki

(Difference between revisions)
Jump to: navigation, search
Revision as of 05:22, 7 April 2011 (edit)
Deanna (Talk | contribs)
(Legend Improvement)
← Previous diff
Current revision (06:34, 7 April 2011) (edit) (undo)
Deanna (Talk | contribs)
(Legend Improvement)
 
Line 118: Line 118:
[[Image:Link_to_variables.png]] [[Image:Link_to_variables.png]]
 +[[:Category:Origin_8.5.1|Back to main page...]]
 +
 +== Context-Menu Improvement ==
 +More menu commands were added to the context menu for the layer icon.
 +
 +[[Image:Short-cut_menu_for_layer_icon.png]]
 +
 +In addition, if a line plot or a line+symbol plot is connected by spline or b-spline, the spline/b-spline data can be created and stored in a worksheet. Simply right-click on the plot and choose '''Create Spline/B-Spline Data''' from the context-menu.
 +
 +[[Image:Create_spline_Data.png]]
[[:Category:Origin_8.5.1|Back to main page...]] [[:Category:Origin_8.5.1|Back to main page...]]

Current revision

Contents

Back to main page...

[edit] Color Palettes

Origin provides built-in color palettes, as well as the ability to create user-defined palettes. The Style toolbar includes a palette icon, which can be used to add or edit a graph’s color palette.

  • Apply palettes anywhere you would use increment color or a color map, including surface and contour plots, bar charts, matrix data (in image mode), and matrix thumbnails.
  • Apply palettes directly from the Style toolbar without having to open the Plot Details dialog box.
  • Change palettes with a single click.
  • Load additional palettes by clicking More Palettes… and browsing to any file location.


Image:PaletteSelector.png
Palette selection fly-out from the Style toolbar

Back to main page...

[edit] Layer Contents Dialog Box

  • Double-click the layer icon or select Layer Contents... on the Graph menu to open the Layer Contents dialog box. (To open the Plot Setup dialog box, press and hold the Alt key while double-clicking the layer icon.)
  • The Layer Contents dialog box is divided into two panels. The left panel lists available columns, matrices, or loose datasets (depending on your selection from the Available Dataset dropdown list). The right panel displays existing datasets in the current layer.
  • Both panels display useful information about datasets in table form. Right-click in either panel to customize your view of the data. Click column headers to sort. These settings are retained when the dialog box is closed and reopened.
  • The Current Plot Type button (located between the two panels) allows you to select a plot type when adding a dataset to a graph. In Auto mode (indicated by an A), plot data is added using style holders in the template, or an applicable plot type. For example, when adding Z data to a 3D graph from a matrix, the 3D Line plot type is automatically used. Double-click a row in the left panel to add that data using the currently selected plot type. Double-click a row in the right panel to set the current plot type to that row’s plot type.
  • The Plot Setup and Layer Properties buttons in the Layer Contents dialog box open their respective dialog boxes and close the Layer Contents dialog box.
  • Use the commands in the right panel to group or ungroup data, change data order, or change plot type.


Image:851beta2layercontents.png

Back to main page...

[edit] Tick Locations from Dataset

The Scale tab of the Axis dialog box includes controls for specifying datasets for tick locations. The controls are in the Tick Location group, and allow users to specify both major and minor tick label locations using datasets.

In the following picture, the bottom X-axis ticks and labels have been specified using column C of the worksheet. The top axis has been turned on and its labels have been set to Tick-indexed dataset with column D as the associated dataset.

Image:TicksLocation.png

Back to main page...

[edit] Box Chart

The Mean Line feature draws a line at the mean value of the data, across the box. If data is also displayed with the box the mean line will cover both the data and the box. When Mean Line is turned on, a Line tab appears. Select the Line tab to customize line settings.

Image:851beta2boxchart.png
Image:851beta2boxchart2.png

Back to main page...

[edit] Histogram Dialog Box

  • The Data tab on the histogram Plot Details dialog box includes a Number of Bins control.
  • The Data tab includes a Go to Bin Worksheet button.


Image:851beta2histogram.png

Back to main page...

[edit] Error Bar Plot

  • Error bars can be drawn as lines, with fill color between the error bars and the data:
image:Errorline.png


  • Error bars in the polar graph can be drawn as arcs:
image:ErrorPolar.png

Back to main page...


[edit] Group tab and Increment Editor

Group tab features include:

  • Easily save and load increment lists. Simply right-click and select Save Increment List... from the menu. Once saved, user-defined increment lists can be selected from the context menu.
  • Right-click and select Load Palette to choose from a list of pre-existing palettes, or browse to load user-defined palettes.
Image:Grouptab.png

Increment Editor features include:

  • These ordering commands: Move Up, Move Down, Move to Top, Move to Bottom, and Delete.
  • Press and hold the Shift key while selecting to move or delete multiple items.

Image:IncrementEditor.png

Back to main page...

[edit] Legend Improvement

You can control the level of substitution in graph legend text. With the Link to Variables (%,$) drop-down list in the Programming Control dialog box, you can enable or disable the translation of the strings that contain "%" and/or "$", which allow you to link the legend to LabTalk variables. If you want to enable the notation translation, you can use this drop-down list to further specify the level of the translation.

Image:Link_to_variables.png

Back to main page...

[edit] Context-Menu Improvement

More menu commands were added to the context menu for the layer icon.

Image:Short-cut_menu_for_layer_icon.png

In addition, if a line plot or a line+symbol plot is connected by spline or b-spline, the spline/b-spline data can be created and stored in a worksheet. Simply right-click on the plot and choose Create Spline/B-Spline Data from the context-menu.

Image:Create_spline_Data.png

Back to main page...